Internal Error After Selecting Azure AD from Authentication dropdown from Users App

Hi ,

We have Outsystems 11 version installed and I wanted configure Azure AD on Our OS server for that I have performed following steps.

  • Accessed Users Application on browse.
  • Login With Admin credential.
  • Clicked on Configure Authentication.
  • Selected Azure AD.

After Selecting Azure AD I'm Getting "Internal Error An internal error occurred and was logged.
Please try again later or contact the administration team." Attaching Screenshot.


Can you please provide any suggestion to solve this issue Any help will be Appreciated.

Thank you.

Sandesh Arjune 

Hi There,

This issue is fixed now, here is how we solved this issue.

Azure AD screen Was unable to load when we were selecting Azure AD from  Authentication dropdown in User Application.

We Raised The Support Ticket to OutSystems , support team  did Analysis and come up with solution.

In Our Case Some Dummy data was there so with the help of support team we took backup of below tables, post that we deleted the content of each table. 

OSUSR_6wd_CfgFBin ,OSUSR_6wd_CfgSP; ,OSUSR_6wd_CfgIntrn;OSUSR_6wd_CfgFile;OSUSR_6wd_CfgIdP;  OSUSR_6wd_Config_UserMappings


Thanks,

Sandesh Arjune 

Hi Sandesh,

Have you gone through this,

https://success.outsystems.com/Documentation/11/Developing_an_Application/Secure_the_Application/End_User_Management/End_Users_Authentication/Configure_Azure_AD_Authentication

Please check this how to configure azure ad may it will help you ,

Regards,

Komal

Hi Komal,

Thank you for response!

I'm stuck at  choosing Authentication(Azure AD) from dropdown. can't procced further.


Thanks,

Sandesh Arjune

Hi There,

This issue is fixed now, here is how we solved this issue.

Azure AD screen Was unable to load when we were selecting Azure AD from  Authentication dropdown in User Application.

We Raised The Support Ticket to OutSystems , support team  did Analysis and come up with solution.

In Our Case Some Dummy data was there so with the help of support team we took backup of below tables, post that we deleted the content of each table. 

OSUSR_6wd_CfgFBin ,OSUSR_6wd_CfgSP; ,OSUSR_6wd_CfgIntrn;OSUSR_6wd_CfgFile;OSUSR_6wd_CfgIdP;  OSUSR_6wd_Config_UserMappings


Thanks,

Sandesh Arjune 

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.