[Physician Relationship Management] Problems working with xlsm files
Forge component by Miguel Baltazar
Application Type
Traditional Web

I am trying to work with xlsx files, (this is the first time I have done it) but I can't get anything to work, I have tried several components of the forge and the same thing happens to me, so I understand that it is a problem of knowledge of these files.

I have an xlsm template to which I want to add text on a specific sheet, so far so good. Services Studio does not skip any problems. Then I try to download the resulting file but when I open it in excel I get the error: "Excel cannot file xxx because its format or extension is not valid. Check that the file has not been damaged and that the file extension is not valid. matches the file format "

Anyone else has happened?

Hello @CrisSanz,

Based on your post I have not been able to figure out how you are working with an xlsm template within OutSystems, I, however, wanted to focus on your problem with xlsx files. 

You mentioned that you are unable to get anything to work with xlsfiles. Are you not able to open the xlsx files upon download? If so please make sure you are choosing the right mime-type in your download widget. 

For e.g. the default mime-type for the 'Download' widget is "application/octet-stream". This works for me to download and view an xlsx file. If that doesnt work for you, you can try the following mime-types for Excel - 

  • application/vnd.ms-excel (official)
  • application/msexcel
  • application/x-msexcel
  • application/x-ms-excel
  • application/x-excel
  • application/x-dos_ms_excel
  • application/xls
  • application/x-xls
  • application/vnd.openxmlformats-officedocument.spreadsheetml.sheet (xlsx)

Hope this helps,

Regards,

AJ

Hi  CrisSanz,

Check your file name extension when you are downloading it.  I got same error when I changed the file name .xlsx to .xlsm extension while opening the file in ms office.


 

So. if it is so , changed name of file name with extension .xlsx . 

Read Mircrosoft Documentation regarding such error.

https://answers.microsoft.com/en-us/msoffice/forum/msoffice_excel-mso_win10-msoversion_other/excel-cannot-open-the-file-xxxxlsx-because-the/a59b7054-1b96-4d84-a554-6069ec050148



https://support.microsoft.com/en-us/office/repair-a-corrupted-workbook-153a45f4-6cab-44b1-93ca-801ddcd4ea53?ui=en-us&rs=en-us&ad=us 


I am unable check your component because it is deactivated now.

There are other many component and their demo. Please check them too.


Thank you.

I think there was an error in my first message. I have no problem working with .xlsx files, but with .xlsm files, which do not work with any of the forge components

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.