[Data Grid Reactive] Issue with Save/Load user view
Forge component by Bruno Martinho
Application Type
Reactive

Hi


Thanks for the recent update. I am trying to implement save and load user view.

I am not getting it to behave as expected, (or am I using in wrong?). I can reproduce the problem in the sample: https://personal-ww5hcsw8.outsystemscloud.com/DataGridSampleReactive/SaveGridView

with this:

1. Save the current view as "Save user A"

2. hide first three column using the "menu" in the top left cell

3. (Not needed to reproduce - Save the view as "Save User B".)

4. Pressing "load user A" does not give me the view as it was before hiding the three columns.

5. Setting all column visible again, and pressing "load user B", gives me Bs saved view correctly (with three coumns hidden).


Am I using this wrong or is this a bug?


Regards

Bård


Solution

Hello Bård,

We just published a new version fixing the issue.

I would ask you please, to take a look on the new version and answer us if wall the issues are now fixed.

Thank you for helping us improve the component.

Ricardo Valim

Hello Bård,

We are looking at this!

We'll give feedback as soon as we have a fix.

Thanks,

Bruno Martinho

Solution

Hello Bård,

We just published a new version fixing the issue.

I would ask you please, to take a look on the new version and answer us if wall the issues are now fixed.

Thank you for helping us improve the component.

Ricardo Valim

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.