React 16 double redirect after splash

In a new "clean" mobile app compiled with the React 16 runtime I get a weird behaviour after the splash screen.

When the splash screen completes loading I get redirected twice to the default screen. I noticed this because sometimes I can see the animation twice.

I also added a client variable that increments every time the default screen is loaded and I can see it incrementing by 2 at a time. I validated the behaviour also in debug mode.

When I try to run the app in the browser I don't get the same behaviour: sometimes I stay in a infinite loop in the splash screen, the other times the behaviour is as expect.

In the attachments I added the .oap file. You can install the apk using this link: App (tmribeiro.outsystemscloud.com) 


Regards,

Tiago

SplashReact16.oap

Solution

Hi @Tiago Ribeiro 

I checked your .oap and it matches the issue we fixed.

Best regards,

Carlos Xavier

Hi @Tiago Ribeiro 

I installed it on my device and works well.

You shared the apk.

Can you share the oml?

Regards

Gonçalo Almeida

Hi @Tiago Ribeiro 

Thanks for the report, I was able to reproduce it in the browser.

We have already dealt with this issue and the fix will be released in the next feature patch.

If you could share your .oap just to make sure it is the same issue it would be super!

Thanks,

Carlos Xavier

Great @Carlos Xavier because my side worked as expected in the browser and on my device.

Regards

Gonçalo Almeida

Hi @Goncalo Almeida and @Carlos Xavier,

Thanks for the quick replies.

By mistake I uploaded the wrong file, you should have the .oap available now. Good to hear this is being worked on!


Thanks for the help,

Tiago Ribeiro

SplashReact16.oap

Solution

Hi @Tiago Ribeiro 

I checked your .oap and it matches the issue we fixed.

Best regards,

Carlos Xavier

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.