using LDAP inside case management application
Application Type
Reactive
Service Studio Version
11.8.7 (Build 29639)
Platform Version
11.8.2.19074

I have converted the workflow builder application to a service studio application to do some customization on it in the development environment. First thing I need to enable the authentication using AD accounts after that I will work on integrating OutSystems roles and groups with AD details. 

The development environment I am using already configured to use LDAP Authentication by other developers and it it is working in some previous applications. When I try to login in to my app using my AD account the login failed for me, I don't know if there is any specification I should do on the project level or it should work just by configuring it in the Users Application in the environment level. 


Appreciate any help.


Thank you dears for the response @Ricardo Pereira @Goncalo Almeida 

I discovered the reason of the issue, it was related to authorization and roles, not authentication. The user I am trying to log by doesn't have the role to access the project created by the workflow builder. This leads to another concern related to managing the access of users in workflow converted application  https://www.outsystems.com/forums/discussion/69510/workflow-builder-managing-user-roles-in-the-converted-project/ 



Hi @Kawthar Ebrahim 

If the login from other apps is working, go to one of those apps and check what is different, even some configuration at the app level.

Regards

Gonçalo Almeida

Hi,


I don't know if that is the case, but many times, when factories have more than one user provider (like using the default from Outsystems and another one that is configured in other application that isn´'t from 'Users') you need to change the application User Provider Module for the one that you desire.

Did you already checked the user provider in your new application (the one that you converted from workflow builder) if this is one of thoose cases?


Hope this can help.


Best regards,

Ricardo M Pereira

Thank you dears for the response @Ricardo Pereira @Goncalo Almeida 

I discovered the reason of the issue, it was related to authorization and roles, not authentication. The user I am trying to log by doesn't have the role to access the project created by the workflow builder. This leads to another concern related to managing the access of users in workflow converted application  https://www.outsystems.com/forums/discussion/69510/workflow-builder-managing-user-roles-in-the-converted-project/ 



Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.