Error installing the Agile Platform Services on Windows 7

Error installing the Agile Platform Services on Windows 7


I'm new working with the platform and until now I’ve done a few tutorials available online (the “How To…”) deploying the application on the cloud available for testing.

Now I wanted to deploy on a local server and try to develop my own applications. For that I’m trying to install the full version of the Agile Platform and I’m having the following error:

Some of the Agile Platform Services failed to start or to register their network ports.

In attachment you can see the entire message.

My operating system is Windows 7 and I’ve already disabled the Windows Firewall, Windows Defender and the Anti Virus and nothing… the message keeps coming.

Also, in the “Windows Logs” of the “Event Viewer” I get the following stack trace error:
Initialization error: System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it
Server stack trace:
   at System.Net.Sockets.Socket.DoConnect(EndPoint endPointSnapshot, SocketAddress socketAddress)
   at System.Net.Sockets.Socket.Connect(EndPoint remoteEP)
   at System.Runtime.Remoting.Channels.RemoteConnection.CreateNewSocket(EndPoint ipEndPoint)
   at System.Runtime.Remoting.Channels.RemoteConnection.CreateNewSocket()
   at System.Runtime.Remoting.Channels.SocketCache.GetSocket(String machinePortAndSid, Boolean openNew)
   at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.SendRequestWithRetry(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream)
   at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.ProcessMessage(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream, ITransportHeaders& responseHeaders, Stream& responseStream)
   at System.Runtime.Remoting.Channels.BinaryClientFormatterSink.SyncProcessMessage(IMessage msg)
Exception rethrown at [0]:
   at OutSystems.HubEdition.DeployService.Deploy.#4Sb()
   at OutSystems.HubEdition.DeployService.Service.ReallyStart()
   at OutSystems.HubEdition.DeployService.Service.StarterThread()
Retrying in 30 seconds

The message in the error suggests that the firewall is blocking the address but I don’t know how it’s possible if I’ve already disabled the firewall and everything that could block that address.
Appreciate any suggestion that could help me solve this issue.
Best regards,
Hi Pedro,

Thank you a LOT for all the details surrounding the problem you have, especially in your first post. I regret hearing about it, but I have to congratulate you on all your effort. This way we'll hopefully be able to hlep you faster.

The error message reports that the port might be in use. Indeed, one frequent cause for that is either Windows Firewall, Windows Defender, or an anti-virus application.

However, in your case, since you already tested it all, I would re-enable the firewall, anti-virus, and anti-malware software - we wouldn't want you to have some malicious virus break in to your computer thanks to it :)

Some common applications that also occupy ports are other application servers, database servers, or P2P clients.

Check this guide for a way to identify which application might be using the ports 12000 to 12004.

I hope this helps.

Let us know if it helps - and what the culprit applications are, so that we know in the future!Re


Paulo Tavares

Thank you for your quick reply.
I've checked the guide you suggested and could confirm that neither one of the ports (12000 – 12004) was in use…
I believe that the installation of the 2005 SQLServer is correct (I could connect to it using the Windows Authentication type).
I’ve tried to install on a Windows XP machine and the installation was successful, but the problem is that I need it on a Windows 7 (64bit) machine for the development.
Next I’ve tried to install the Platform Server (PlatformServer- and the installation was successful.
In the ConfigurationTool I’ve tested all the connections (Admin, Runtime and Log) successfully.
When I tried to execute the command SCInstall.bat I get the following error:
Service Center Installer v5.1.1.8
Start installing Service Center v5.1.1.8...
Publishing Extension(s)...
Message 1
  Id         :
  Type       : Error
  Message    : Unable to contact Outsystems Deployment Controller Service
  Submitable : True
  Details    :
  ExtraInfo  : Module :
Message 2
  Id         :
  Type       : Error
  Message    : Unable to contact Outsystems Deployment Controller Service
  Submitable : True
  Details    :
  ExtraInfo  : Module :
And when I try to connect to the local server (localhost) in the Agile Platform I still get the following message:
“There was an error contacting ‘localhost’: Host not found.”
Any help would be appreciated.
Hi Pedro,

Well, those errors are to be expected if the services aren't started.

Have you tried to manually start the OutSystems services? You can do it manually, in the Windows Services panel, or you can execute the "Start  Services" command, under OutSystems > Administration Tools.

EDIT: Actually, one thing came to mind, regarding Windows 7. Does the user who is installing the Platform have Administrator privileges on the machine? That would help.

If that doesn't work, do check the Windows Event Viewer's error log, and let us know what you find.

If we can't solve this through here, we'll go to our support department, so the more information the better :)


Paulo Tavares
The user installing the Platform has administration privileges.

I executed the “Start Services” under OutSystems > Administration Tools and I believed it started successfully (no error message appeared). Is there any other way to check if the services started correctly?

In the event viewer there were also no errors, only informational messages of the services starting. The source of the messages is “MSSQL$SQLEXPRESS”.

The messages I posted before still appear when I run the SCInstall.bat or in the Platform when I try to connect to localhost or to the IP
Best Regards,
Pedro Paiva
Hi Pedro,

Well, I'm submitting this to our support department, so that they can follow up with this.

In the meantime, the way for you to check if the services are started, would be to access the Services panel from Windows.

In older versions, if I recall correctly, it was located under Control Panel > Administrative Tools .

In Windows 7, however, click the start menu, and in the search input type Services .

If all went right, you should see the 5 OutSystems services as Started (or at least the OutSystems Deployment Controller and the OutSystems Deployment Service), and the World Wide Web Publishing Service, for IIS.

Also, you should have a SQL Server service Started, with your catalog name. In my computer it is "SQL Server (OUTSYSTEMS)".

If any of those haven't started, start them manually.

Also, do follow these steps:

- Execute the Platform Server Configuration Tool. You can access it under Start Menu > OutSystems > Administration Tools;
- Click the "Upgrade Database" button;
- Check the Ports definitions under the Logs, Scheduler and Controller tabs;
- Click the "Ok" button, and restart the services;
- Execute the SCInstall command, in your Platform Server hard disk folder.

If these don't work, let me think about it...

Is IIS running, at least? Can you successfully ping ?

And what about SQL Server? Can you access it through the SQL Server Management console?

If so, a thing you could try to do is to change the ports for the services, in the Configuration Tool.

The defaults are:

Log Service Port: 12003
Scheduler Port: 12002
Deployment Controller Service Port: 12000
Deployment Service Port: 12001
SMS Connector Port: 12004

Let us know how these go.

Wouldn't you per chance have another web server installed in that machine - Apache, Tom Tom, or another website running in IIS?


Paulo Tavares
Hello again and thank you for your patience,
The ISS is running, I can ping the address or localhost.

No other web server installed.

In the SQL Management Studio I can access to the SQLEXPRESS Server threw the “Windows Authentication”. Although I can’t access the outsystems database. I get the message “The database outsystems is not accessible.”

In the Services panel the 5 services were not started. I had to start them manually.
I only have the default SQL Server (SQLEXPRESS) and this one was started.

After starting the Outsystems Services manually e tried to run the “SCInstaller.exe” (this time I executed de command prompt of the 64bit “\Windows\SysWoW64\cmd.exe”) and I think it executed successfully. This was the message:
Service Center Installer v5.1.1.8
Publishing Extension(s)...

After all of this, I still can't access the ServiceCenter. I'm sending the printscreen in attachment.

Pedro Paiva
Hi Pedro,

I apologize for the negative reply, but it would seem that Service Center has not been installed correctly. If you're getting a 404 message, I am led to believe that it hasn't been deployed in the server.

I am running out of ideas, sadly.

What is the result of clicking the "Create / Upgrade Database" button in the Configuration tool?

As a worst case approach, I will suggest you look into our .NET Installation Checklist, and follow the step-by-step installation. Maybe there's something obvious that has gone wrong, and we're just missing it :)

Let us know how it goes.

Paulo Tavares
Hi Pedro,

Can you send us a print screen of your IIS manager tree expanded?

I would also like to ask if you could send your OutSystems Installer logs to Located at "C:\Program Files\OutSystems\Installer\")

In the mean time I would like to ask you to validate if you have an Application Pool (within IIS) with the name "OutSystemsApplications" with the settings:
  • .Net Framework v2.0
  • Enable 32-bit Application false
  • Managed Pipeline Mode Classic
Can you also validate if you have the Application Service Center within this Application Pool?

Best Regards,
Renato Gonçalves
I'm just chiming in to say that I had the exact same problem as the OP.  I checked to see if anything else was using that port and found nothing.  However, manually starting the services worked.  Thanks!  And hopefully this helps someone else!

"Have you tried to manually start the OutSystems services? You can do it manually, in the Windows Services panel, or you can execute the "Start  Services" command, under OutSystems > Administration Tools."
Hi Jordan,

Thanks for the feedback. Indeed, since there are multiple configurations of Operating Systems, and each one then has its own set of users, user permissions, and other software installed, there really is no silver bullet for solving these problems, so we try to suggest all the things that we think may be related.

I'm glad to hear that one of the suggestions worked out for you :)

Let us know how everything goes!


Paulo Tavares