[OutSystems Charts] Do reactive chart overrule UTC datapoint labels?
Forge component by OutSystems R&D
Application Type

We are migrating a dashboard from traditional web to reactive web.
Our DataPoints use UTC labels as datetimes for the x-axis.
So we keep useUTC on true (or don't define it), and work with a TimezoneOffset of 0 (both default values).

In my DataPointList I have a starting value (0-index) with label at the first of April at 00:00:00.
This is correct.

However, the visible Highchart is moving our Datapoints to the Local time (Europe/Amsterdam).
So the first x-axis label is now converted to 'Mar 31, 22:00'.

In the HighChartJson file we define time as follows. Note that these are the default values.

time: {
        timezoneOffset: 0,
        useUTC: true

I have also tried to set the global Highcharts.options with this same config, but that also doesn't help.
The configuration is working, because if we move timezoneOffset to -120, it is working.
But this is not what I am expecting. The labels of the datapoints are in UTC.

Do you have any clue how to tell the Highchart component to just use UTC and don't convert anything?
Is there a setting in a reactive app to tell it the timezone it has? And is that impacting the Highchart?

Many thanks in advance

I found out, this problem is not caused by Highcharts.

The problem is related to the way Reactive apps handle date times in the UI. Every datetime is handled in UTC, unless you show it in the UI in Reactive apps. Then it is converted to the client timezone.

I have posted a new question, how to disable or overwrite this default behaviour.

yes you just  doing good  bro.. you can try these steps                                                                                                             

Enable data locations

 If your dataset does not contain a location field, you can enable location with these types of location: coordinates, addresses, or geography.  After enabling the site, a new site field is added to the dataset.  With the location field, you can create maps and perform spatial analysis with the data.

 Enable location for data collection

 1. From the dashboard, click the Dataset options.  2. Click Enable Site.  3. Choose the type of site.

 Note: Enable location with coordinates and address location types are not supported for linked database datasets.

 2.3 Insights Documents

 Make selections for the following parameters: ???? • Field from the X (Longitude) and Y menus

 (Circles of latitude) • Different spatial reference if you like


 Make selections for the following parameters:

 • Geocoding service if there is more than one service.

 • District of address.

 • Below the address fields, choose one field if the site description is in one field.  Multiple choose if the site description is separated across many fields.

 Matches fields that match the title field or fields in the dataset.

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.