[Firebase Mobile] Firebase Push Notification  - Default sound not playing in IOS
Forge component by David Sousa

Hello everyone,

In IOS, Push notifications do not wake up with the standard notification sound from the phone. Notifications come in, but the phone doesn't alert

Has anyone been through this too?

Cheers,

Neide

Hi Nedie,

In the body of the sent notification from the server, have you put: "sound": "default" in the body of your request? Something like this:

{
    "to" : "...",

    "notification" : {
      "body" : "...",
      "title" : "...",
      "sound" : "default"
    }
  }

Regards,

Hasan

Hi Hasan,

I use the server action "SendNotificationToUser" and in the UseCustomSound parameter I use the default value, "False"


Thanks,

Neide

Hi Neide,


Can you give it a try to put "default" in the UseCustomSound  parameter?

And also some checks are good to be performed at the mobile level, such as the notification manager settings in your phone.


Regards,

Hasan

Hi Hasan,

The UseCustomSound parameter is a boolean and only receives values "true" or "false".

Regards,

Neide

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.