[SSL Pinning Plugin] "syncWrapper is not a function" on App Resume
Question
Forge component by OutSystems R&D

I'm getting this error after I installed this plugin successfully just after I go to another app and move back to my app with SSL Pinning installed.

The first time I resume the app, I got this syncWrapper message. But after I start to navigate to other screens, no error is triggered anymore.


Any suggestion in here?

mvp_badge
MVP

Hi guys, any clue in here?
It is happening only in PRD and after that error, block all trigger sync in our application

Hello Rafael, 


Can you provide us with a bit more details on the issue to help us to understand the problem better?

  1. What is the SSL Pinning Version you are using? 
  2. Is it happening for Android or iOS or both?
  3. From what I can understand, this is an issue when you move the app to the background while is making network requests, correct? If you disable the SSL Pinning, don't you get the same error?  

Beste regards, 

Vitor

mvp_badge
MVP

Hi Vitor, I'm using 6.0.1.

It is only happening for iOS and when the env is set as PRD, for non-prd it is fine.

I tried changing some tech preview options (like react 16 and optimizations true or false), but it is active in all envs and only have issues with SSL Pinning + IOS + PRD

When the app is resuming, it fails in the splash loading (around 20% of the progress bar) with the syncWrapper error and all the sync requests after it doesn't run. When I set the PRD env as a non prd, it works. Pretty strange.


Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.