[Image Editor Plugin] Cannot read property 'editImageFromBase64' of undefined
Question
Application Type
Mobile
Service Studio Version
11.10.20 (Build 41361)

I'm trying to edit a photo upload from my camera, and even though the data exists an the conversion to base64 worked succefuly - the edit segment raises an error.

Here's the general flow:


And debugging values:

I entered the output values in this link:

https://base64.guru/converter/decode/file

and it's presented well. 

Hi,

You must check the presence of Cordova plugins in your app in order to avoid later errors.

I think that you are testing your app from the browser. The functionality of Cordova plugins can be tested in native mobile applications only.

Kind regards, David.

@David Vaello thanks for the response.

Unfortunately, I receive the same error from my mobile (Android). As far as I saw, the dependencies of this app requires Outsystems UI dependency which is installed with the latest version.

Are there any other Cordova elements I should download from forge?

Thanks!

Yedaya

Hi,

Are you generating the mobile app with MABS and then you install the apk or ipa? In your screenshot it looks like you are testing your app from the mobile browser. 

The value of CheckImageEditorPlugin.IsAvailable is true when you can use the cordova plugin in your mobile app. For example, when you test your app from the mobile browser, this property will be false because the cordova plugin only can be used from mobile app (or in some cases with PWA).

What are you getting in this property?

Kind regards, David.

A clarification: for the Image Editor Plugin Sample, it is different open the app in the mobile browser than native app:

Mobile Browser

Native Mobile App

In the mobile browser, we will get a jscript error if I do not check the availability of the plugin.

Kind regards, David.

Hi David,

Thank you very much for the detailed response. I tried to deploy the application as you mentioned in order to test the editor, but I some how this plugin blocks the deployment. Everything begins well:

but then fails with this error message:

There's clearly a relation between the Image plugin and this error since when I remove the plugin - the app is deployed easily. Is this something you're familiar with? am I missing something regarding the implementation of the plugin?

This is this what I currently see when opening the app:


Thanks again,

Yedaya

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.