CKEditor - Spell Check As You Type ( SCAYT )

CKEditor - Spell Check As You Type ( SCAYT )

How to activate the Check spelling as you type (SCAYT)? For when I try to enable displays an error?

Detalhes dos erros da página da Web
Agente de Usuário: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; InfoPath.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; OfficeLiveConnector.1.4; OfficeLivePatch.1.3; MS-RTC LM 8)
Carimbo de data/hora: Thu, 3 Feb 2011 14:29:57 UTC
Mensagem: 'sc_dojo' não está definido
Linha: 16
Caractere: 1
Código: 0
Hi Wellerson,

Sorry for the late reply. Indeed, that looks liks a CKEditor error in itself, as there are similar ones reported in their own bug tracker.

Have you tried it with CKEditor's latest version? You can get it at their website.

What about in other browsers?


Paulo Tavares
It seems to work fine in CKEditor with version 3.5 of CKEditor  (I've updated/attached my CKEditor 3.5 version).  To make the SCAYT function work, I dragged an expression immediately after the CKEditor web block, and pasted the following in the extension and set it to not escape the text:

"<script type='text/javascript'>CKEDITOR.config.scayt_autoStartup = true;</script>"

Nice tip Ken!
Tks for your cooperation. 

This is great, looks fantastic! I am having some trouble though. I can type in the CKEditor text box, but I cannot make any action save what I have typed, it will only save the original text. Any ideas?


Hi !

The above given solution has worked. Is there a solution where I can enable SCAYT by default ? So that I do not have to enable that option manually and disable it manually.

Thanks in advance.
Add scayt_autoStartup: 'true' to the editor config
@ Gerry - Thanks !!