[Touch ID Plugin] Bugs in TouchId plugin
Question
Forge component by OutSystems R&D
Application Type
Mobile

Hello, 

I face a lot of issues using this plugin. For some cases a discussion already exists, but I would like to bundle them into one large place to discuss this component. 

I am using version 3.3.0 of the component, which is the latest version.

The first question I have is regarding the MaxAttempts input parameter which is unused in the component.

The second question is regarding the CheckBiometricType. On my android I have both touchId and FaceId. When I use the TouchId client action, it automatically detects the fingerprint, but when I use the client action CheckBiometricType on the same phone, it returns FaceId. In other words, I would like to have a fingerprint icon shown when the system detects fingerprint as main biometric and the same for FaceId. However, this currently doesn't work because CheckBiometricType returns a 2 (faceId) while the plugin itsself uses fingerprint as biometric type in the TouchId client action. It seems to me that either CheckBiometricType or TouchId is not working properly. 

The third question is regarding a phone with both methods (most android phones). In the current implementation it seems impossible to have the user choose the biometric type if it has multiple. Is this assumption correct?

I would like to hear if anybody else has the same issues

Kind regards,

Tyler

Hi OutSystems R&D, 

I saw your response in my email, how soon do you guys think that the patch version will be released?

Thanks in advance.

Tyler

Hello Tyler, 


We released last week a new version of the plugin. For now, it's under development version, but you can try it. 


Best regards,

Vitor

Hi Vitor,

I am happy to try out the development release in my DEV environment but I want recent fixes in my TEST and PROD. Can't go ahead with the 3.3.1 on PROD.

Do you have a stable release coming soon?

Regards,

Ravi

Hello Ravi, 


We just moved today the version to stable. 


Best regards, 

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.