[Inline Value Edit] Discussion

[Inline Value Edit] Discussion

  
Forge Component
(9)
Published on 2011-04-18 by Hugo Pinheiro
9 votes
Published on 2011-04-18 by Hugo Pinheiro
Hi!

I created this component because more and more Web 2.0 applications use inline editing for speed up data entry and to imporve usability. I wanted to understand how easy it was to do it in OutSystems and it took me about 2 hours to complete.

I have already detected some issues in chrome for right adjusted fields and also with mandatory field validation but it seemed cool enough to release and have some of you guys, out there, propose some improvements or new approaches to it.

Just donwload, install the OSP (you need 5.1, EM and RIchWidgets for the sample) and take a look.

Cheers:

    Miguel
Hi Miguel,

Like the widget!
In the sample there's a small typo; you might want to eliminate.

Site.ApplicationName:
"Inlide Edit Sample"
I think you mean:
"Inline Edit Sample"
This widget doesn't work for combo boxes.
Hi:

No... it does not work for combo boxes YET... You are welcome to add to it! ;)

Cheers:

    Miguel

PS - I will correct the Typo ;) Thanks for poiting it out!
Hi Miguel,

I've modified the EditWidget so you can enable / disable it.
Disabling it makes that you cannot edit the line and the edit icon isn't shown.

This is useful if you don't  want to allow editing for certain roles.
It's saved using SS 5.1.1.9; but maybe you can 'revert' this so older versions can use the function too.

Regards,

Eric
Hi Eric,

Wow, thanks for the new version. Miguel: if you feel this is ok, will you upload this new version to the component? :)

Regards,

Paulo Tavares
Hello,

I have used this widget recently and notice that dont work for inputs with more than one ligne (Textarea), so I've modified the EditWidget to works for Textareas and for combo boxes too.

Cheers,

Hugo Pinheiro
On the combo boxes it was showing the value instead of the option text.  I have updated the code so that it is showing the text.
This latest version has IPP enabled, @Paulo, maybe you can remove it for all of us?

http://screencast.com/t/to3MwjSbsdR

Hans
Hello Hans,

What version of the solution you have? I just download it and dont have IPP enable.

Regards
Hugo Pinheiro
Hi,

Tested the latest version in FF4.0.1.

It looks great and I have also some issues that prevents me to use it...

- I noticed the red "mandatory asterisk" on the first letter of the names.
- when i click on a name, the table is moving a lot. Is there a way the columns are kept steady?
Hi all,

I'm loving this component but having trouble with any text which is quite long. At the moment i have the component in a table widget, but the table columns expand to be as wide as the text, but when i click to edit the input widget is the size I specify. Is there any way to wrap the text?

Cheers,

Tom
Hi...

can you please discribe the steps to use inline widget...

i am trying to use it ,but its not working for me.i drag it in a column name part no at list screen,and assign value
ProductTable.List.Current.Product.PartNumber and enable "True"

Best Regards
Israr
Hi Israr,
 
You need to create a text box which has the variable ProductTable.List.Current.Product.PartNumber in your list widget.
 
 You then need to assign the values the Inline widget needs, which will be the Id of the Textbox you created.
 
 Hope that helps, I had the same problem when I first used it. You bascially need to create all the textboxes you want and the widget will do the rest of the work for you.

Let me know if you have any trouble.

Tom
Hi Tom

for example i have a table record that display the product List, ok..
so i need to drage one textbox beside every column in table record, and then assign the ids of those text boxes to inline widget...??
and in case of show screen we will do same ...?
can u provide an oml exemple.....

would be highly apreciated.....

Best Regards

Israr

1. Assign a Name to your field widgets in the list (i.e. PartNumber)
2. Rather than "ProductTable.List.Current.Product.PartNumber" use "PartNumber" (to use more than one seperate them with a comma)
Hi Rebecca.

thanks for the reply...

its solved...

Best Regards

Israr
Does this solution work in Service Studio Version 7.0 ? Why is EM and RichWidgets required for this solution to work ?
Hi Ravi,

The Service Studio will upgrade the eSpace when you open it. The EM references you can remove it and correct the errors, the use of EM it's only for sample porpose.
Hi

I am unable to publish and use this widget in Service Studio Version 7.0.

 Pls see the attached error
You have to change the user provider, in the eSpace click on the eSpace name, and you will find that option.

 
Hi Nuno,

Thanks a lot for your suggestions. It works now.

Regards
Ravi