Request failed with an error - No logs
Application Type
Mobile
Service Studio Version
11.11.0 (Build 42743)

Hi All, 

I run into a problem where every time I contact the server (e.g. login or client actions trying to reach the server) I get the following error: "Request failed with an error". 

This is a (Debug type) mobile application that is built using Service Studio (Distribute). This application is only applicable for Android. 

When I test the mobile app in the browser with the simulator I don't get this error. 

Is there anyone who ran into the same problem who could possibly help me? 

Thanks in advance!

With best regards, 

S. Kaushik


Hello @Savvy Kaushik 

I faced that error and the cause was the device was not connected to the internet. 

In my case, my device had a problem that can not connect. 

Regards

Gonçalo Almeida


Hi Goncalo,

Thanks for your comment. I have checked whether the device is connected to the internet. This is the case. I checked this with the "GetNetworkStatus" action.

So unfortunately the problem has not been solved.

Greetings,

Savvy

Hello @Savvy Kaushik,

If you have an on-prem OutSystems installation, it might be worth checking if a valid SSL certificate is installed on your server. Hope that helps in your case. 

Seems like you just have to go through a process of elimination one by one, as there can be a variety of root causes.

Regards,

AJ

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.