Unable to publish after 5.1.1.9 upgrade

Unable to publish after 5.1.1.9 upgrade

  
After upgrading the platform and studio to 5.1.1.9 I am unable to publish either through Service Studio or Service Center - both generate the following exception.  I've looked here for a solution, but none of the proposed solutions has resolved the issue. 

HELP!!

System.Runtime.Remoting.RemotingException: 6 arguments were passed to 'OutSystems.HubEdition.ICompiler::CompileOmlAsync'. 7 arguments were expected by this method.

Server stack trace:
   at System.Runtime.Remoting.Messaging.Message.CoerceArgs(MethodBase mb, Object[] args, ParameterInfo[] pi)
   at System.Runtime.Remoting.Messaging.Message.CoerceArgs(IMethodMessage m, ParameterInfo[] pi)
   at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg, Int32 methodPtr, Boolean fExecuteInContext)

Exception rethrown at [0]:
   at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
   at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
   at OutSystems.HubEdition.ICompiler.CompileOmlAsync(Byte[] oml, Boolean debugMode, String espaceName, Int32 espaceVersionId, String testAreaName, Boolean forceDontReuseTables)
   at OutSystems.NssOMLProcessor.CssOMLProcessor.MssCompileEspaceAsync(Boolean ssDebug, Byte[] ssOML, String ssEspaceName, Int32 ssEspaceVersionId, String ssPTA, Boolean forceDontReuseTables, RLHEMessageRecordList& ssMessages, Int32& ssErrorCount, String& ssErrorText)


Server stack trace:
   at System.Runtime.Remoting.Messaging.Message.CoerceArgs(MethodBase mb, Object[] args, ParameterInfo[] pi)
   at System.Runtime.Remoting.Messaging.Message.CoerceArgs(IMethodMessage m, ParameterInfo[] pi)
   at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg, Int32 methodPtr, Boolean fExecuteInContext)

Exception rethrown at [0]:
   at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
   at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
   at OutSystems.HubEdition.ICompiler.CompileOmlAsync(Byte[] oml, Boolean debugMode, String espaceName, Int32 espaceVersionId, String testAreaName, Boolean forceDontReuseTables)
   at OutSystems.NssOMLProcessor.CssOMLProcessor.MssCompileEspaceAsync(Boolean ssDebug, Byte[] ssOML, String ssEspaceName, Int32 ssEspaceVersionId, String ssPTA, Boolean forceDontReuseTables, RLHEMessageRecordList& ssMessages, Int32& ssErrorCount, String& ssErrorText)

Module : 
Hi John

How exactly did you perform the update to 5.1.1.9? Did you installed the Platform Server 5.1.1.9 component following the 5.1 installation checklist document for revision update, or installed the Agile Platform Community Edition full installation 5.1.1.9 instead?

From the error you're getting, it seems that the Service Center management application was not updated, and is still running the old version, while the services are already running the new 5.1.1.9. Make sure you follow all steps on the installation checklist document referred above, in particular, make sure the scinstall.bat command runs without exceptions.

Cheers

Miguel Simões João
I did a platform update, followed the outlined steps, but something must have gone wrong in the original SCInstall statege, as t ran in a couple of seconds.

When I went back through the steps again, it ran much longer and I seem to be OK now.  Thanks for the help.