Aggregate Incorrect Syntax near '\' warning
Question

Greetings, I created an aggregate where it has a filter by ID and is sorted descending by ID. I can't seem to see the data due to the warning "Incorrect Syntax near '\'".

I also check the executed SQL

Dear Wilbye

  1. Can you show the Filter & Sorting you have added in aggregate? 
  2. Also, if possible please share the OML with us to handle this. 

Filter:

Sorting:

I will need OML to see for further help. 

it seems like you've created within your aggregate an alias for your entity containing quotes. 

When I created the aggregate, I just dragged in the Entity that I'll be using, how do I remove the quotes? I can see the quotes in the executed SQL

can you show us the first tab of the aggregate? 

regards Hans

Oke.. is it an external entity and if so from which type of database? 

Another idea could be that debugging/logging of queries is enabled and that it doesn't work on your database see https://success.outsystems.com/Documentation/11/Developing_an_Application/Troubleshooting_Applications/Trace_Executed_Queries_Back_to_Your_OutSystems_Applications?_gl=1*i9a64y*_ga*NTE5NTg5NTM5LjE1NjY0ODk5MTA.*_ga_ZD4DTMHWR2*MTYyMzE3NDIzNy41MC4xLjE2MjMxNzQ4NjAuNjA. But when reading the article I don't expect this is the problem.

Hans

it is an external entity, it's from mariaDB. I have other tables from mariaDB and they seem to work fine.

Hello @Wilbye Descalsota,

I was wondering how you are able to view the Executed SQL when you encounter a warning while obtaining Preview data.

As for the issue itself, this happens sometimes if you have just edited your code and attempt to Preview before you publish your changes. If this applicable to you, I would suggest publishing your code and and then preview.

Regards

AJ

I published first before trying to view the data.

Hi Wilbye,

As it is not a very large or complex aggregate, could you delete it and create the same from scratch.

I know this is a very unsatisfying way of solving problems, but there is a (small) chance that the problem will be gone, and if not there is a chance that we will learn something new from this...

Dorine

Yes, it is not a complex aggregate. Delete the aggregate or delete the table from the external database??

I already tried deleting the aggregate before and created a new one, I get the same issue.

Even in advanced SQL I experience the same issue,

Is it possible that the issue is from the Outsystems Integration Studio?

I think I fixed it, I went to the Integration studio and saw that my Logical Database and Identifier were missing. please do confirm if these are the fix.

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.