[Input Masks Library] Maxlength and Enable property is not working for NumberMask
Forge component by Labs
Application Type
Reactive

Hi All,

Maxlength is not working in Input mask Library plugin for Numbermask input.  Enable property is set to false when i gave any condition to the enabled property.

Herewith i have attached the oml and the link. Kindly suggest some solution

https://ellakkiya-selvadurai23.outsystemscloud.com/MaskInput/Inputmask?_ts=637592676136789710


Regards,

Ellakkiya.S

MaskInput.oml

Solution

Hi @Ellakkiya S ,

This should be fixed in the latest version (1.1.5).

Best regards,

Carlos Xavier

Hi,

I separate this  question into two:

1. MaxLength not working

Answer: In HTML input type number or input mode numeric is not support max length attribute. you can achieve it using javascript

2. Enable Property not working while using condition

Answer: Enable property will not update on runtime. To achieve it you can use javascript.

For Reference, OML attached

MaskInput.oml

Hi satiz,

Thankyou for your reply,

In the case1,  Input field is of text datatype. Maxlength is not working for the input field which is binded with the NumberMask. 

In the case2, Your solution suits for single condition. But, In my case I am having 100 input field in single page. And also serveral condition for enable and disable the particular input field.

Note : Maxlength and Enable property is not working for the input's binded with NumberMask and CurrencyMask.

for Custom mask, enabled property is working as expected.


Regards,

Ellakkiya.S

Solution

Hi @Ellakkiya S ,

This should be fixed in the latest version (1.1.5).

Best regards,

Carlos Xavier

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.