Bootstrapping an Entity from Excel.
Application Type
Traditional Web

When I bootstrap entity from excel . The excel is getting bootstrapped, but when I view data it is shown as No records to show. What might be the issue here?

image20210614T144130454Z.png

I got my excel bootstrapped to the entity. By creating an upload widget and a button by default. For the button, I have performed a custom bootstrap action. Refer to the image below.

image20210617T110620769Z.png

mvp_badge
MVP

Hi Ahmed,

Have you published the application after the bootstrap?

Have you checked the service centre for any error logs?

regards,

manish jawla

Hi Manish,

After bootstrapping the excel  I published the core module but still, it is shown as no records to show.

And also I checked the Error Logs, I don't find any errors regarding this issue.

regards,

Mohamed Zubair Ahmed


mvp_badge
MVP

Hi Mohamed,

As Manish asked, please make sure that you have published the module after doing the bootstrap. 

When we bootstrap entity from excel it actually saves your selected excel file and creates a timer, this timer actually executes after module is published and saved data from excel to your entity.

You can read all information here: https://success.outsystems.com/Documentation/11/Developing_an_Application/Use_Data/Bootstrap_an_Entity_Using_an_Excel_File

One more thing you should note here is that after publishing the module, you timer may take some time to execute and save all the data to entity so your data may take some time to appear on screens.


Hi Nikhil,

Yeah, I published twice checked the table, and also I waited for a long time for data to be loading . But still, it is shown as No records to show. But excel has 700 records will that be a problem?

mvp_badge
MVP

700 rows should not be an issue, only impact it may have is delay in bootstrapping the data.

Ideally if data is not appearing even after timer execution is completed, it means there is some error or issue with logic.

You said there is no error in service center so probably there is some issue in your logic. Can you share a minimal oml with issue.

Champion

Dear Mohamed

Can you ensure you have not used any filter that might stopping data to show? 

Also where are you looking data after bootstrap? - Is it Data Tab itself or the Aggregator? 

Number of records will not impact this, there is something else. If you find everything fine please try to bootstrap again. 

mvp_badge
MVP

Mohamed,

In Service Center go to 'Monitoring > Timers' as the showed at the picture, and see if the timer that create the data have ran or if it has any error next to it.



As Nikhil pointed, the data will be created after the timer runs. And in this screen you can check if it have ran without problems :)


Cheers and Regards,


RR :)

Hi Nikhil,

  I'm getting Timer BootstrapSheet1s error  type of error in service center.

Screenshot20210616163431.png

mvp_badge
MVP

Hi @Mohamed Zubair Ahmed,

Can you debug the timer action which is created by scaffolding? and let us know what's happening inside that action? I am sure it will trigger on publish event or you can trigger the timer from the service centre via run now option.

Regards,

Manish Jawla  

In bootstrap action there will be a create action, instead of Create action we need to change it as  Create or update action and map the local variables inside it and then need to publish . Then, the data is fetched and displayed.

Screenshot20210615235740.png

I got my excel bootstrapped to the entity. By creating an upload widget and a button by default. For the button, I have performed a custom bootstrap action. Refer to the image below.

image20210617T110620769Z.png

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.