Line Chart not showing single value on it

Hi
I am working on the line chart of the highchart in the outsystems version 11. I have data in the entity & is date specific.
e.g. for the 1 day  may have more than 1 records it could be 10, 50, 100 etc.

I am trying to show it on weekly basis to do that i have written advanced sql query. Query returned correct data as expected. When i plot or bind this data on the line chart it shows correctly as expected.

But problem occurs when i have only one record for any particular week.

In such case data is not showing that one single entry on the line chart.

So i am not sure what's the issue is it because of any DATA or CSS or jQuery

LineChart1.PNG

Hi Pradip,

can you share either your oml (preferably), or screenprints of your datamodel, your sql statement, and the result data of your sql ?

In the chart you attached, what week is missing a datapoint ?  And can you show the value in your sql result for that week ?

Dorine

Sorry i can not share the details because of the client privacy policy.
Thanks for the help.

I got the solution i will share it.

It was happening due to some CSS issues. Few CSS gets overrides with the chart background & also set few json attributes for it.

plotOptions: {
        series: {
            fillOpacity: 0.1,
            marker: {
                        enabled: true,
                        symbol: 'circle'
                     }
                }
            },
Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.