Refreshing modules independently of the server - not possible rn

I notice that I have a forging component being used on different servers, if I have the client-server open with that component when I change something in the same component on "my" company's server and want to update it in the modules where it's being used also shows client-side modules to update.

And i don't have obviously any references.

When I say client-server, I say, the server from the client

Hi Marcio,

Just to check if I have understood you correctly.

You have a forge component on an environment, and this component is being used by multiple consumer modules.

When you change the forge component, all the consumer modules indicate that they need to be refreshed?

If i have not understood you correctly, could you please specify the issue some more?


Thanks

Shahin

I have one environment consuming one forge component, and there is the client environment where has the same forge component. I am doing some changes on the forge component in "my" environment and when I am going to refresh the modules that are using that component in my environment it shows the client environment too to refresh because the client environment has also the same forge component. 

Thanks for the explanation. How are the environments separated from each other? Are they different outsystems installations (on separate servers)? Is it cloud/on-prem installation?

And where exactly does 'it' show that the client environment also needs to be refreshed?


No problem :) This is not affecting me, I am just trying to see if it's or not the right behavior.

What I do is, I open different instances of OutSystems, I enter on both environments, and sometimes I just leave it opened just o see the work from the client. 

It shows when you click on the tab Module and below Download Consumers is refresh All open Consumers.  And when there are changes it says the modules to refresh, in this case, is saying the modules from "my" environment and the client environment.


Thanks, that makes it a lot more clear. I ran into such a scenario as well. I tried to capture it using a gify (see attachment).

What I noticed: when you have two instances of Service Studio openned, with the same module OR it's consumers, then there is a weird link between the service studio instances. 

To explain the attachment, I tried to replay your situation.

- There is a module IdentityRelationship (in short: producer) which has a consumer AzureAuthProvider (in short: consumer).

- There are two environments, A and B. Both environments have the producer and consumer modules published.


Suppose I have both environment A and B openned at the same time (2 Service Studio instances). Environment A has the producer opened, Environment B has the consumer opened.

- I change the producer in environment A and publish. 

- Service Studio says that Consumer is outdated (in environment A).

- When I click on open consumer in Environment A, it does not open the consumer in Environment A. Because it somehow sees the consumer being opened in another service studio instance. Even if that is a different environment, in this case environment B.


My guess is that this is either a bug in service studio, or the way it is designed to work. In either case, it is not ideal. So be careful when having two instances of Service Studio opened at  the same time.


Hope this helps.


Shahin

Environmentsdependencies.gif

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.