Using "requireCordovaModule" to load non-cordova module "xcode" is not supported.
Question


getting below error while generation the IOS app. had attache dthe log file.

Build failed with the following error: Error installing Cordova plugin: cordova-plugin-firebase. Using "requireCordovaModule" to load non-cordova module "xcode" is not supported. Instead, add this module to your dependencies and use regular "require" to load it.

somebody please help.
iOSBuildLog.txt

Hi Harshad,

The problem is with firebase plugin. Please update your plugin in latest version.

I think you tring to generate application in MABS 7 that's why you got this error.

Hope this will help you

Hi Harshad Chaudhari,

As @Swapnil Shinde mentioned, error is due to the firebaseplugin.

Check whether the MABS version that you have used while generating the application does support the Firebase plugin.

And also check the MABS version of plugin.

Regards,

Ellakkiya.S

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.