Menu missing in browser but visible in Service Studio

Menu missing in browser but visible in Service Studio

I have added a few Entity edit screens to my application by dragging and dropping them onto the Web Flow. This automatically created the menus as expected, but after publishing and browsing to the eSpace the menu is missing. Any ideas where to begin looking?
Hi Eric,

While it'd be hard to know without looking at your eSpace, I'd actually suggest changing the default Entry point's connection from the default webpage to one of the webpages you created after dragging your entity.

It might require you to login (use admin/admin), but do let us know if that works.


Paulo Tavares
OK...If I changed the default Entry point's connection to a webpage I created after dragging the entity onto the webflow. The menu was visible. I deleted all webpages NOT created in this method and then added a new webpage. Once again the menu displayed in Service Studio on the new webpage but not in the browser after publishing.
If this is just a matter of reinstalling the platform that's no big deal, but I would like to know why it happened or where to look for a cause. I don't want to have to reinstall if it happens again.
Hi Eric,

Actually, it seems much more like a bug from our end, either that or there's something you're doing that we aren't really expecting, or some kind of mistake on our end.

Could you send us your eSpace, and let us know exactly what you're doing to create new pages - literally, where you're dragging what, to where?

Regards, and thanks for your help in troubleshooting this situation.

Paulo Tavares
Thanks for helping me figure this out. I will attach the OML file now.

With the MainFlow visible in the workspace, I am dragging the "Web Screen" icon from the toolbox on the left and dropping it on the workspace in the MainFlow.
Hi Eric, have you checked the permissions on that new menus being created?

Does the user you're using have those permissions?

Best Regards,

Diogo C S Cordeiro

(The obviousity of the obvious might not be so obvious)
Hi Eric,

From looking at your eSpace, it seems to be what Diogo is mentioning. Does this happen when you login with admin/admin (or the administrator login, if you have changed it)?

For this to work for the user you're testing it with, you should grant the proper permissions to your users, since each user may eventually see only some of those screens.

I'm not sure this explanation is clear, but please let us know if it's not - or if it still doesn't fully explain the behavior you're experiencing.


Paulo Tavares

I am logging in as either admin or myself and still I cannot see the menu ON ONE PAGE ONLY - MAINMENU.

I have checked all permisssions boxes on every page and still this issue persists.

Once again, I can see the menus on every webpage with the exception of the webpage entitled "MainMenu"
I see the expression granting permissions on each menu item, but as I said I am logging in as Admin, which has all permissions.

Where else can I look?

Hi Eric,

The issue is that the Header web block only displays the menu IF the ActiveTopMenu <> NullIdentifier (you can open the web block and see the IF's expression). In your MainMenu you're passing NullIdentifier as the ActiveTopMenu. Edit the Header web block's IF expression, and just make it TRUE :)

I deeply apologize for the trouble it's been causing you, and I hope this solves it.

Let us know if this helps. I've also forwarded this situation to our team, so that they can look into it in future versions.


Paulo Tavares

After reading your last post, I see what you are talking about. Instead of changing the IF to "TRUE" I set the ActiveTopMenu for MainMenu to the first one in the list and also the ActiveSubMenu to the corresponding item. That worked.

I'm okay with this workaround until the problem is fixed permanently.

Thank you, Paulo and Diogo, for your help!


I'm just starting outsystems (service studio 6.0) but I am having a problem similar to the problem as described in this topic. 

In an application which is in developement, I added a new entity.

I created an Entity_List screen, an Entity_show screen and an Entity_edit screen. 

The problem is that after publishing the menu isn't showing in my browser on my created pages (it does show in service studio). However, on other pages (list, show, and edit screens relating to other entities) the menu is showing.

After some research I noticed the IF-statement is, as Paulo mentions in this topic, ActiveTopMenu <> NullIdentifier. I would like to try Paulo's solution: Edit the Header web block's IF expression, and just make it TRUE :). 

1st question: I am looking for information on how to make the IF expression TRUE because I don't know how. Thanks.

Because it is a common web block, Paulo's solution may influence the menu in other pages. So my second question is about Erics'  workaround.

2nd question: Eric writes: 
I set the ActiveTopMenu for MainMenu to the first one in the list and also the ActiveSubMenu to the corresponding item. That worked.
It would be nice to get some clarification about what list Eric is talking about, and what corresponding item he describes (and why changing the ranking of a list works).

Thanks in advance for your answers.