Error in Service Studio on iMac when trying to open a screen

I'm using Service Studio on Apple iMac. This version of Service Studio is 11.50.9 Build 46307. When I'm using example apps from Forge or from the community I run often into an error when I'm trying to open a screen under UI Flows. See attached screenshot with error. 

When I'm building myself an app and add/open/change screens on iMac I don't get this error. And on a Windows version of Service Studio on my laptop I can open the screens of the apps from Forge or the community succesfully. So I suppose this error has to do with the fact that the OSX version of Service Studio is still yet under development. 

I'm preferring to use Service Studio on the iMac instead of using it under Windows on a laptop with a small screen. I was wondering if there would be a workaround for this issue? E.g. do something first in the Windows version, save it and reopen it on the iMac? Does anyone have a tip for a successful workaround?

ScreenshoterroropeningscreeninServiceStudioforiMac.png

Hi Kevin,

I think it would be helpful if you open a support ticket for this scenarios, if you facing problem in iMAC service studio.


Dileep

Hi Kevin,


I know it's not the same thing but I can think of 2 workaround solutions for now:

  • Install Outsystems on your Windows laptop, then control it from your iMac using RDP. 
  • Install Service Studio on a Windows VM inside VirtualBox.

Hi Maxime,

Thanks for the tips.

  • I already had installed Service Studio on my laptop, and tried to control it from my iMac using RDP. I run into an issue because it's a business laptop, probably this isn't solvable.
  • I already had installed a VM (Parallels) on my iMac. This works normally very well, but in the case of Service Studio it isn't. Service Studio won't open and the VM is then not working anymore. I will look in this issue further.

Hi Dileep, I shall open also a support ticket for this.

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.