Updating another entity with a calculated value retrieved from yet another entity


I am trying to update an Order Total field in an Order record each time I add a new Order Item

Here are some screens.

Seems like I should be able to calculate and add to the order but it doesn’t seem to find the Product key. Any thoughts? .omi attached





CustOrd71921.oml

Hello Alan,

I have Modify the your OML and i have notice you are passing the details with the preparation filter before create the value the didn't pass the output that's why you are facing 0 key Error for reference I have Attached working OML and URL

https://akshayproject.outsystemscloud.com/CustOrd71921/OrderItems.aspx



Thanks and Regards,

Akshay Deshpande

CustOrd71921.oml

mvp_badge
MVP
Solution

Hi Alan,

Based on the shared .oml file, I had below-metioned observation  

  • The mapped/referenced variable in the Assignment & GetOrder node in the Save action flow is not correct i.e. instead of referring to the Aggregate attributes value refer to the Form runtime Record attributes value
  • The exection in Assignment node is Top to Bottom approach
  • You can get rid of the local variables

Refer to the attached .oml file


I hope this helps you!


Kind regards,

Benjith Sam

CustOrd71921.oml

mvp_badge
MVP
Solution

Hi Alan,


The error you are getting is you're trying to fetch a product which does not exist.


I did a couple of changes in the OML in attachment, it should be working now.


Kind Regards,
João

CustOrd71921.oml

mvp_badge
MVP
Solution

Hi Alan,

Based on the shared .oml file, I had below-metioned observation  

  • The mapped/referenced variable in the Assignment & GetOrder node in the Save action flow is not correct i.e. instead of referring to the Aggregate attributes value refer to the Form runtime Record attributes value
  • The exection in Assignment node is Top to Bottom approach
  • You can get rid of the local variables

Refer to the attached .oml file


I hope this helps you!


Kind regards,

Benjith Sam

CustOrd71921.oml

Hello Alan,

I have Modify the your OML and i have notice you are passing the details with the preparation filter before create the value the didn't pass the output that's why you are facing 0 key Error for reference I have Attached working OML and URL

https://akshayproject.outsystemscloud.com/CustOrd71921/OrderItems.aspx



Thanks and Regards,

Akshay Deshpande

CustOrd71921.oml

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.