Roles id's do not match Role Entities Ids
Application Type
Reactive, Service
Service Studio Version
11.11.10 (Build 46822)
Platform Version
11.10.4.29633

Hi i'm trying to get Group id that have certain roles by comparing the Role.id using the Roles function to a role in OutSystems. (this role is part of a different application but the role is made public:



This is done in an aggregate:


i can see that the Role id is no longer got when previewing the Role table but a Error message is shown instead:


But if I get the Role.id of the CustomerCareWaiverSpecialist and directly compare that role.id to the role.ids of the Role table it works.


E.g:


Why can i not use the Roles.CustomerCareWaiverSpecialist = Role.id on the table filter ?

Is there another way ?

Thanks
Gayan

Solution

I just tried the above and seems to work fine. With the exception that Outsystems studio itself can't seem to display it at design time. 

I assume you did include a reference to the role from the other application in your espace? If that is probably the issue, Roles.CustomerCareWaiverSpecialist is actually an object and you need to include it in your espace to reference it. EDIT - ok yeah you must have otherwise it wouldn't have published

Yeah not sure what occurring but appears to now work possibly due to to a reference update , but it still doesn't show in the IDE.

Thanks
Gayan

Just in case try refreshing references of BOTH espaces and republishing, the one with the roles first. I have had object not found errors in the past because of out of date references.

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.