Cordova plugin: phonegap-plugin-push problem for MABS7.0
Question

Hi Team,

we used Cordova plugin: phonegap-plugin-push for push notification. It was working fine till MABS version 6.2. However, when app generated with MABS7.0, it is failing generating app with below error. Basically Platform.json is missing, But not sure how older MABS has no issue.

ERROR - "In Android on 2021-08-09 at 10:37:25 - Error installing Cordova plugin: phonegap-plugin-push. Due to security concerns, the required dependency for the '/var/lib/builder/builds/82d43da1-4fe8-43f2-9002-c0ae64436dfd/source/platforms/platforms.json' node module in a plugin hook was missing. For more details, check the product documentation on how to ensure your plugins node dependencies." 

Appreciate if anyone facing any issue like this and solve this issue


AndroidBuildLog.txt

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.