[Camera Plugin] Plugin version incompatibility with MABS
Forge component by OutSystems R&D
Application Type
Mobile
Service Studio Version
11.11.12 (Build 47321)

Hi Community,

Today I updated the Camera plugin to the latest version (7.0.7) so that we can use the latest MABS version. Unfortunately I am getting the error below and I am not sure on how to solve this. As you can see in the image below the cordova-plugin-camera is 4.2.0-OS9 and not 4.0.3-OS5 as stated in the error message. I also did a reinstall of the camera plugin but no luck on that. 

It seems to be something in the application itself, because I made a new mobile application and made a reference to the camera app and added a button to take a photo. Generated the application and no problems. I also removed the whole dependency from the camera plugin and still getting the error. Any ideas of where this problem could be? Where to look?




Hi Bart ,

As you have mentioned, the Camera plugin is working fine in the Demo app.
It's not working in your application only .
I think in one of your modules ,you have added https://github.com/OutSystems/cordova-plugin-camera#4.0.3-OS5 as Extensibility Configuration.
Please try to find and remove that .

After that if you try to generate a build , it should work fine.

If you have any queries , feel free .


Hope It Helps,

Kind Regards ,

Vivek P.


Hi Vivek,

Thanks for your reply. I found the problem and I never knew this could be causing it. A long time ago we made a clone from the camera plugin to adjust the quality (and a few other things) that are now standard in the newest version. This clone is NOT included in this application that is providing the error and is a dependency of another app but for some reason this application is failing because of that. Not sure why the demo app is not giving the same error though. I removed the clone and updated the other app to user the newest camera plugin.

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.