[Html2PdfConverter] Getting error 'Problem generating PDF from HTML, URLs'
Forge component by Miguel 'Kelter' Antunes
Application Type
Traditional Web

We are getting an error on our production environment from last week when we try to generate an PDF from html. The same functionality is working on development server and UAT server but getting error on production environment.

We tried generating PDF with different URL like on development and UAT server which are working correctly but our production server with URL  is only giving error as seen below.

We created a small POC in DEV environment  to see if the production URL works fine with the same component in DEV/UAT, it did not work. 

Could you please let us know what is the issue here.  

Hello Nitesh, 

Did you config the app in Prod? If dev and QA are working probably you need to enter in the configs from the HTML2PDFconverter in prod environment and finish the configurations.


Best regards

Carlos Lessa

Hello Carlos,

i have alrady done that and it was working from last 1.5 year but suddenly it started giving error on PROD, DEV and UAT are working fine.

here is the prod admin settings, i just uploaded new binaries after reading  new instructions but still issue occurs. 

Hello @Nitesh Ahirwar,

1. Your screenshot did not show this so I had to ask, is the "Write Binaries to Running Dir" unchecked? (Should only be checked for Personal environments)

2. If there is a screen involved in generating the PDF report, please make sure the screen is accessible by the Anonymous Role. Maybe, just maybe this setting is somehow different in Production.

Regards,

AJ

Yes AJ , 

"Write Binaries to Running Dir" is unchecked

 

And yes html which is generated is accessible anonymously.. this has been working since last year but suddenly started giving error. 

Also i have tried uploading latest binaries but still error is coming.

Nitesh, try to reinstall everything.


Delete the files,  download the latest binaries, upload again.

If doesn't work, delete the app, and start from zero, upload from Forge the latest version and binaries and install again.

Check if something change on your directory, if somehow lost permission to write.

Or try to log and check any errors when you try to install/update and follow the path on the log to find where the problem occurs.



Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.