[OutSystems UI] LightboxImage - Undesired behavior on close
Forge component by OutSystems R&D
Application Type
Reactive

Hi everybody!

I'm trying to present a list of small images - no issues.
Then, as the images are small, I'm making use of the OutSystems UI WB LightboxImage to make possible for a user to expand the clicked image and see it bigger and with better quality - no issues as well

Now it cames the issue:
When closing the the bigger image, I noticed that the data of the page is fetched again, refreshing the list and causing a blink like effect.
I've been trying some other options and it doesn't matter if the list and remaining data cames from an aggregate or a DataFetch action. I also get the same result from whatever source the image being clicked is loaded.

You can see the issue by yourself at :

https://edubaixo.outsystemscloud.com/AppDummy/LightBoxDummy   (simple list with local image)

I was expecting that once the user closes the bigger image, that the page would remain still without refreshing any data.
Does anyone know how I can achieve that?

Thanks ;)

Solution

Hi @edubaixo,


I'm sorry you're facing issues with the LightBoxImage!

I believe that might be related to the history feature of the library used. If you add the class 'disable-url' on the ExtendedClass parameter of the LightBoxImageBlock, it should fix this issue.



Let me know it it helped!


Best regards,

Bernardo Cardoso

Hi Bernardo!
Adding the class 'disable-url' on the ExtendedClass parameter of the LightBoxImageBlock did the trick!

Thank you for your help :D

Hello there,

The link that you have provided is not working. Http service unavailable error is showing. But, it's fine I am providing you a link for documentation. If you haven't visited it I will recommend you to go through it once.

https://success.outsystems.com/Documentation/SILK_UI_Framework/03_Building_UI_Through_Pattern_Composition/Using_Silk_UI_Patterns/LightBoxImage_Pattern

I hope it helps you :)

Regards,

Abhinav

Hi Abhinav,


It seems that my enviroment was under maintenance when you tried to access it, you may try it now :

 https://edubaixo.outsystemscloud.com/AppDummy/LightBoxDummy   (simple list with local image)


Also, I had seen the documentation already, It doesn't seem to relate with the issue I stated here.

Solution

Hi @edubaixo,


I'm sorry you're facing issues with the LightBoxImage!

I believe that might be related to the history feature of the library used. If you add the class 'disable-url' on the ExtendedClass parameter of the LightBoxImageBlock, it should fix this issue.



Let me know it it helped!


Best regards,

Bernardo Cardoso

Hi Bernardo!
Adding the class 'disable-url' on the ExtendedClass parameter of the LightBoxImageBlock did the trick!

Thank you for your help :D

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.