[Ultimate PDF] An error occurred while generating the pdf for "####" Failed to launch browser!
Forge component by Leonardo Fernandes
Application Type
Traditional Web, Reactive

Hello,

We having this error using the last version of Ultimate PDF and Ultimate PDF Traditional Web:

An error occurred while generating the pdf for "OUR URL": Failed to launch browser! [0903/092100.840:ERROR:network_change_notifier_win.cc(228)] WSALookupServiceBegin failed with: 0
[0903/092100.856:ERROR:os_crypt_win.cc(70)] Failed to encrypt: The system cannot find the file specified. (0x2)
[0903/092100.856:FATAL:headless_browser_main_parts.cc(103)] Check failed: OSCrypt::Init(local_state_.get()).
Backtrace:
IsSandboxedProcess [0x00007FFB1A3D1842+705042]
IsSandboxedProcess [0x00007FFB1A3539A2+189298]
IsSandboxedProcess [0x00007FFB1A362AF8+251080]
IsSandboxedProcess [0x00007FFB1A3639E0+254896]
RelaunchChromeBrowserWithNewCommandLineIfNeeded [0x00007FFB1BBA2123+12980755]
RelaunchChromeBrowserWithNewCommandLineIfNeeded [0x00007FFB1BBA1E8D+12980093]
ovly_debug_event [0x00007FFB18995929+16331561]
ovly_debug_event [0x00007FFB18D55B17+20264215]
ovly_debug_event [0x00007FFB18994675+16326773]
ovly_debug_event [0x00007FFB189973BE+16338366]
IsSandboxedProcess [0x00007FFB1AE47DB7+11675527]
CrashForExceptionInNonABICompliantCodeRange [0x00007FFB1A2EA837+8179991]
CrashForExceptionInNonABICompliantCodeRange [0x00007FFB1A2EB5AD+8183437]
CrashForExceptionInNonABICompliantCodeRange [0x00007FFB1A2EB20C+8182508]
CrashForExceptionInNonABICompliantCodeRange [0x00007FFB1A2EA1BD+8178333]
CrashForExceptionInNonABICompliantCodeRange [0x00007FFB1A2EA53A+8179226]
CrashForExceptionInNonABICompliantCodeRange [0x00007FFB1A324D1A+8418810]
CrashForExceptionInNonABICompliantCodeRange [0x00007FFB1A324BDC+8418492]
CrashForExceptionInNonABICompliantCodeRange [0x00007FFB1A3249E7+8417991]
ChromeMain [0x00007FFB17A01238+408]
Ordinal0 [0x00007FF63BE726B8+9912]
Ordinal0 [0x00007FF63BE71A41+6721]
GetHandleVerifier [0x00007FF63BFBAF42+904642]
BaseThreadInitThunk [0x00007FFB474384D4+20]
RtlUserThreadStart [0x00007FFB4755E8B1+33]

[0903/092101.059:ERROR:gpu_init.cc(426)] Passthrough is not supported, GL isswiftshader


This is kind of critic, because we use this component for some contracts.

Please anyone already passed for this error?


Component version: 4.0.2

Environment: cloud

Platform version: 11.11.3

Last service Studio version


Changed the revision but the error continue:

I have been getting this exact same error with the upgraded version. I had to revert back to an older version so I could get it working again for now.

Would like to figure out how to get this error fixed though so we can upgrade it.

Hi Leonardo,

After update to last version of component the error reported already has already gone :) 

But now we having another one about certificates i think:

Here the Stack


With the 3.0.5 version works fine.


Regards.


mvp_badge
MVP

Yes, this error is due to a revoked certificate.

Could you check if that address is valid on a current version of Google Chrome?

You can also change the LocalServerProtocol and LocalServerHostname site properties to change the URLs being used to access your screens. I recommend you use a LocalServerHostname that has a valid SSL certificate.

Leonardo,

Yes the url is valid and i can access with the last version of Chrome.

About your solution is a kind of tricky, because we have more than one FE controlled by a load balancer....


I upgraded to the latest version 4.04 and am now getting a time out error when I try to use this. I only have a PDF of 2 pages, so it shouldn't be taking that long to product the PDF I wouldn't think. Do I need to put a default chromium version in my site properties?

Hi Clayton,

We are experiencing a similar issue.

This is the link to my discussion: https://www.outsystems.com/forums/discussion/73114/ultimate-pdf-ultimatepdf-is-causing-an-error-the-operation-has-timed-out/

I have not received an answer yet. 

Have you managed to find a solution?

What I did to fix it was go to the Site Properties for the UltimatePDF module and change the LocalServerHostname from blank to anything other than the environment I'm working in URL.

So for example I changed it to 'dev' for my develompent environment and 'test' for my test environment and then it stopped timing out.

This is listed in the Site Property description which explains why it fixes it I think:

"The hostname to reach the current server. The default is to use the hostname configured in Service Center, which is usually something like acme.outsystemsenterprise.com.  Override this if your server cannot resolve itself by the public DNS name."

I'm assuming my server could not resolve itself by public DNS name.

Here is my error: 

When I update my URL to use the IP Address of my development environment it gets me to this and downloads the PDF: 

It looks like the PDF download works when I change my LocalServerHostName site property value to my production or test environment URLs. When I use my dev environment URL it gets locked up and times out for whatever reason.

I pushed this into my test environment and it won't work if I use the test URL. It will work if I put the dev or production URL in for the LocalServerHostName. Is that how it is supposed to work?

Hi Leonardo,

With the last version in Production Environment, now we have another issue:

mvp_badge
MVP

Hi Fábio, I believe this is fixed by version 4.0.6.

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.