internal error with the OSMDB application
Application Type
Traditional Web

Hi can somebody help me with this internal error. I have tried everything to make it work but it will not work and i am always getting this error message. Thank you in advance for the help

So I did following

implement your 3 core modules

implement your UI module

start application

i get error screen

go to service studio

this is error i see

So now I know where to look, but if you don't, you can also look at the details of the error for more clues

And so looking at the aggregate in the preparation, the source of this aggregate is the Movies entity (from Core_OSMDB) but in your sort clause and in the sort widgets on your screen, you are referring to {Movie} entity (you have one of these in OSMDb__Core.

So that's the explanation for your current error, but really, you should consolidate your 3 core modules into 1 and clean this mess up before continuing.

You could delete everything and start over, following the course notes, and that will work, but a large part of being a developer is bugfixing and refactoring, so starting from what you have now and fixing it might be a much better exercise (but might take you longer than starting over)

Dorine


EDIT : in your earlier comment, you had clearly not been looking at the right error message in service center.  If something fails, pay close attention to the time it happens to find the right error.

Hi Dorine,

Thank you very much for the help. I wil try combining it together and fix the website.

Kind regards,

Erdinc

Hi Erdinc,

we can't really help you with just this message, it is too generic and could be any number of things.

Can you share the oml (both, the screens and the core) and/or go and look into your service center to get more details of the error.

If you haven't used service center yet, it is in your personal environment url/servicecenter, and you need to login with your own outsystems account.

There is an errors page under Monitoring tab, please click detail of the error and share the details you find there.

Dorine

Hi Dorine,

Thank you for your replay. Is the screenshot below the right info to understand what is wrong with it?

mvp_badge
MVP

Hello Erdinc,

Unfortunately, that information only doesn't help (we are basically seeing the 500 internal error that is shown in the screen).

Can you share your OML file so we can take a look?


Kind regards,

Rui Barradas

Hi Erdinc,

that's a bit of a mess, isn't it ?

apparently, from your module OSMDB, you are referencing 3 different versions of the core module !

So there is the OSMDb_Core, that you have shared, but that doesn't have much more than the GetAppName

Then there's the OSMDb__Core, and then there's the Core_OSMDB.

If you are following the course, really, you should only have one core module.


As there's only one of the 3 cores shared here, I can't implement and see what is going wrong with your error.

Dorine

Hi Dorine,

Yes it is. I forget why i had 3 cores made in the first place.
But i will share the other 2. Because i cannot figure out why it is given my the error.


OSMDbCore.oml

here is the next

CoreOSMDB.oml

So I did following

implement your 3 core modules

implement your UI module

start application

i get error screen

go to service studio

this is error i see

So now I know where to look, but if you don't, you can also look at the details of the error for more clues

And so looking at the aggregate in the preparation, the source of this aggregate is the Movies entity (from Core_OSMDB) but in your sort clause and in the sort widgets on your screen, you are referring to {Movie} entity (you have one of these in OSMDb__Core.

So that's the explanation for your current error, but really, you should consolidate your 3 core modules into 1 and clean this mess up before continuing.

You could delete everything and start over, following the course notes, and that will work, but a large part of being a developer is bugfixing and refactoring, so starting from what you have now and fixing it might be a much better exercise (but might take you longer than starting over)

Dorine


EDIT : in your earlier comment, you had clearly not been looking at the right error message in service center.  If something fails, pay close attention to the time it happens to find the right error.

Hi Dorine,

Thank you very much for the help. I wil try combining it together and fix the website.

Kind regards,

Erdinc

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.