Mail not working

Dear All,

In our DEV environment, email is triggering from the system but its not delivered to the recipient. But in Production, the mail is working and recipient receives the mail.

In DEV, the SMTP server and Default Sender mail are given as same as the Production environment.

I have attached details.

Kindly help me to rectify this issue in DEV environment.

Thanks & Regards,

Madhavan

Errormail.png

Hello @Madhavan Selvaraj 

My 2 cents:

1. In Email Configuration settings in Service Center, please check if maybe the emails are being redirected to test recipients:

2. Try a different port in Development. For e.g. if the current SMTP Port is 25, try 587 (a recommended port)

3. Were emails working successfully in Dev before? I believe you would not have deployed to Production if there were issues in Development. If this is correct, maybe the Email Configuration in Development was recently changed but the application was not republished? Please check

Regards,

AJ

Hi @AJ. ,

Please see the comments below:

1)In the DEV environment, I have added my mail id and I am not getting any mail.

2)I have tried in both ports 25 and 587. Both not working.

3)from the starting mail is not working in the DEV environment. Its triggering from the system and not going out.

In the Production Mail is working fine.


Note: In the DEV environment, mail is triggering but not sending out. But in UAT, mail is not even triggering.


Thanks & Regards,

Madhavan

Champion

Hi Madhavan Selvaraj

Is your environment on premise or cloud?

If your email configuration same with product environment, Then may be you should ask your infrastructure's team to confirm the network settings.

>But in UAT, mail is not even triggering.
Also, Can you explain more details about this? Is that mean you can't show the email log in monitoring?


Regards,


Hi @Tom Zhao ,

Our environment is in our own premise.

//in UAT, mail is not even triggering.//

Even though we are not getting any email from the DEV environment, I am able to see mail is triggered from the system through service center.

The below two screenshots are from DEV environment.

DEV Email:


DEV email triggering instance:


The below two screenshots belongs to UAT:

UAT Email:


UAT Email Triggering Instance:


From the above two screenshots from the UAT, email was lastly triggered on 11/11/2020.

Our application went to live on 13/11/2020. Exactly two days before the application went to live, email triggering stopped in UAT.


Thanks & Regards,
Madhavan

Update: 

Infra team worked in the network settings and checked and allow the required ports. In DEV environment, we are receiving the emails now.


But in UAT, the email is not even triggering.

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.