Image not updated in UI but updated in database
Application Type
Traditional Web
Service Studio Version
11.12.0 (Build 48966)

Hi All,

I have used the image widget to display binary data from the database, but when I try to update the image and I save it back to the database, image in UI does not change and the binary data in the database changes

I have tried to delete the binary data from the database and the result is still the same, the UI image doesn't change

Note: Service Studio Version 11.12.0


Thanks All,

Kane

Hello @Kane Loony,

When the Image is updated in the database, do you - 1) Refresh the aggregate; and 2) Perform an 'Ajax Refresh' on the Image widget/ container? Sample screenshot:

Regards,

AJ

Hi @AJ. 

But still not updated in UI


Thanks,

Kane.

Hi @Kane Loony,

It seems you are passing Static value with database binary.. Erase "Untitled1" from image field to resolve the issue.

Check Ajax refresh after changing image in your logic

Good luck

Thanks, Aadhavan S

Hi @Aadhavan Shanmugam ,


Image field cannot be empty,


Thanks,

Kane

Hello,


In this field enter the path to the entity/attribute where you are saving the binary in the database

Hi,

What do you mean by path? because the field is only for image type


Thanks,

Kane

Hello

In the field: 

"Image" you choose an image that will appear by default when none is selected.

"filename" you can choose a name

"Atribute" you choose the field where the image to be updated will be saved in the DB



Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.