[Microsoft Login Connector Reactive] Callback Page not found
microsoft-login-connector-reactive
Reactive icon
Forge component by Miguel Amado
Application Type
Reactive

Hi,

I'm developing an app and I need to use this component. This is working well for azure registered users but for some reason i've received an error on callback page that says that's not found.



I did this configuration on Azure side:


And this one on Service Studio side:


Hope someone can help, thanks!

Hi Diogo,

I see in your first screenshot that the screen that is being redirected to is not the reactive callback page. So I'm not sure why that is. Some debugging should shed some light on that. 

I also notice that you fill in a few parameters that are not needed to fill in when you use a default configuration. Can you please test what happens when you clear the CallbackPageEspaceName and the CallbackPageName?

The configuration in Azure seems to be correct so that should not be the issue. 

Greetings,

Vincent

Hi Vincent,


Thanks for the answer.


I clear the CallbackPageEspaceName and the CallbackPageName fields and nothing happened. Futhermore, I'm already being redirected to the correct page (as you can see in the screenshot), but I've got the same error.



I already compared the 2 links (this one and when I open the "CallbackPage" in browser) and they are the same.


If I set the code to 0 in the input parameters, the page is found and appears another error:


Could it be some configuration on "MicrosoftLoginConnectorReactive" module?


Thanks!

Hi Diogo,

Did you happen to find the cause of this issue? 

Greetings,

Vincent

I have found the issue (at least for my issue). In the reply URL a "new" parameter called session_state is added. Since no screen with the name CallbackPage has this parameter as Input the underlying platform in unable to match a valid endpoint (the regular callbackpage) and gives a 404. Updating this will take me some time since we currently do not run the latest version of this component so I will need to upgrade first. 

And as any good developer I found a reference to this session_state on StackOverflow ;). 

Link: https://stackoverflow.com/questions/24922550/azure-active-directory-session-state

Hi Diogo,

I have updated the documentation of this component with steps that you should take on your environment if you still are having these issues. Some configuration needs to be changed on you platform and the documentation tells you how to do this. 

Greetings,

Vincent

Hi Vincent,

I tried to test the solution that you provided but it only works on personal/trial environments. Do you know any way to solve this issue on this type of environments?

Thanks!

Hi Diogo,

Are you referring to the Factory Configuration fix? If so I'm confused because that fix should not work on the Personal environment since it is a shared environment. It does work on the Hosted environment, I know that for sure because that is what we are using. If you have a on-premise configuration then you can be don't need to use the factory configuration tool, you could configure IIS directly yourself.

So can you explain a bit more what you are referring to exactly and what issue you encounter on your enterprise environment?

Greetings,

Vincent

Hi Vicent,

Sorry, my mistake. What I want to say is that the solution that you provided doesn't works in personal environments (and I'm using a personal environment). Currently, I'm still receiving the same bug (Page not found). Do you have any solution for this type of environment?

Thanks!

Hi Diogo,

I don't have a permanent solution for these environments. You could create a ticket for this issue and hope that support will solve it for you. 

An alternative is changing the URL that is failing. Just remove the parameter session_state together with its value and you should then be below the allowed threshold. The login will then succeed. 

Greetings,

Vincent

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.