Table Record widget empty
Application Type
Traditional Web
Service Studio Version
11.11.13 (Build 47428)

Hi, I have a table record which has a list of values as source. In that table i have two columns, one with a checkbox (with an OnChange action), and other with an expression. The problem is when I access the page on the browser, the table record is filled, but when I click de check box, or the submit button, it does not what I want because the widget list is empty. Any idea about why is empty? 

Thanks,

mvp_badge
MVP

Hi Rui,

Is that possible for you to share the sample oml for reference.

Thanks,

Manish Jawla 

mvp_badge
MVP

Hi Rui,

I have attached the sample .oml for you.

May be this helps.

Regards,

Manish Jawla

CheckboxExample.oml

Thanks . Here is the .oml, and a print screen of the problem.
I click on the second checkbox, and the OnChange brings position 0.
Where position is 

TableRecords1.List.CurrentRowNumber
TESTE1.oml

And this is the print screen

teste1.png

mvp_badge
MVP

Hi Rui,

Please find the attached oml and screenshot, i have made minor changes to your code, now while debugging you can see the records.

Hope this helps.

Regards,

Manish Jawla

TESTE1.oml

Thanks for your help. The use of feedback message in your example give a clue to understand what was happening.

For what I saw, Outsystems checks if the variables that are being assign on OnChange are being used or not. If not, it will not pass values for OnChange. 

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.