[CSVUtil] [CSVUtilExtension] LoadCSVError Garbled characters
Forge component by Wei Zhu
Application Type
Traditional Web

Hi,

I would like to load data from CSV to system database.

CSV content over 100,000 records, over 40MB.

When I import the CSV, Error occurred like picture.


・CSV is selected in standard "Upload" parts.

・Error  occurred before "LoadCSV2RecordList" Action.


Is the cause of the error the size of the file?

https://success.outsystems.com/Support/Enterprise_Customers/Maintenance_and_Operations/Altering_file_upload_limits_in_OutSystems_apps


CSVUtilError.png

Hello YT,

Based on this 2019 post, it does not seem like 100,000 records alone may cause the issue you have encountered. 

Did you you check Service Center to see if there are any 'out of memory' errors logged? 

Regards,

AJ

Hello AJ,

Thank you for your reply.

I confirmed service center ,but 'OutOfMemory' error was not.

I have no idea to solve this error.


regards.


Hello YT

Did you check the message and stack trace of  Error Log ?
If the message are similar with the link  you mentioned , then this would be the size limit.
At that case, you need use Factory Configuration to change the size limit.

Regards
Wei

Hello wei,

Thank you for your reply.

I confirmed stack trace of error log ,but the error was not.
Also, I tried importing an Excel file converted from CSV, but the same error occurred.

Regards
YT

ErrorLogScreen.PNG

Champion

Hi YT,

Have you ever tried with less records to see if you get the same error?

Regards,

Hi Tom.


Thanks for your reply.


I tried importing a csv file containing 50,000 records (100,000 divided into two files), but no error occurred.


I looked at this document (LINK) and changed the upload limit.

No error occurred, but the application became not return any response.

I have tried debugging, but I did not reach "Start".

Before reaching "Start", the application stops running.


Please help me.


YT

hello everyone,


I solved the error.

I confirmed every configuration again, I made mistake it.

sorry...


thank you for everyone.


YT


Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.