Rating variable will not be filled

Hey everyone,


I am making a rating filter, but when i click on a rating star then i see no value on it when i debug it. Can anybody help, its my first week in outsystems. Here some screenshots maybe it will help.


Thank you for helping!

Thanks you all for you help. i dont know why it works now. But 1 put an extra argument in the events and it works!

Hello Stefan De Vaan,

Nice that you found a solution, I hope my perspective helps to solve the issue.

I also change my example:

https://personal-gxzlvs5j.outsystemscloud.com/Rating/HotelRatings?_ts=637716159052217801

Now when you click on "Rating Stars" also sort by that "Rating".

Best Regards,

Nuno R

Hello Stefan,

Could you please share your OML?

Thanks & Kind Regards,

Sachin

Thanks!

HOPselect.oml

Hello Stefan De Vaan,

I look at the OML that you shared and there are some things missing.

I made a little example, check here:

https://personal-gxzlvs5j.outsystemscloud.com/Rating/UserRatings

It´ s this that you want? If yes I share the OML.

Hope it helps,

Nuno R

Rating.oml

Hey Nunu Ricardo Rodrigues,

This is how i want to filter, but i want that i can filter with the rating for example. I want a 5 star hotel. so i select 5 start on the rating. The problem when 1 click on 5 stars my list not filters to only 5 stars. 


I think i do something wrong with handler and value.

Thanks

Thanks you all for you help. i dont know why it works now. But 1 put an extra argument in the events and it works!

Hello Stefan De Vaan,

Nice that you found a solution, I hope my perspective helps to solve the issue.

I also change my example:

https://personal-gxzlvs5j.outsystemscloud.com/Rating/HotelRatings?_ts=637716159052217801

Now when you click on "Rating Stars" also sort by that "Rating".

Best Regards,

Nuno R

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.