Users in version 6

Users in version 6

  
Hi,
Just downloaded version 6 service studio.

When opening an oml from 5.1 a lot of errors show up in user relateded areas.
Questions?

1- Need to convert manualy the code?
2- Any HOW TO doc for conversion from 5.1 to 6 ?
3- Any tool?

Probably its just my ignorance but I could not find the answers.
Thanks.


Hi Orlando,

Older applications were using Enterprise Manager. For them to work you need to either change them to only use Users or upload Enterprise Manager. Check the "Enterprise Manager Upgrade to 6.0.pdf" document included in the zip to understand the changes and what you can do. 

Cheers,
Tiago Simões
Do you have a link to the pdf?  I didn't see the pdf in the zip file.
Rebecca, the PDF is inside "Upgrade from version 5.1" folder.


The users management is in the new Users eSpace, but Enterprise Manager has some more things, like the application backoffices.
What happens to the backoffices we have in Enterprise Manager? Do I need to create an eSpace for them?
Thanks Tiago.
Found the Zip and the PDF.
Followed the instrutions BUT: when uploading the enterprise manager 6 to the cloud allways get a time out error.
Using Solution pack tool 6.0
Any coments?

Hi, again.
I could publish it to the local server, the application is working nicely on version 6, but keep having the timeout error when trying to publish to the cloud.
Can trial users do it as they only have read access to extensions?
regards
Hi.

As per last post could run the app in the local server, version 6.
Was able to publish it on the cloud but cannot login.
Allways get an "Invalid Log..."
Changed the passwd in users and created a new user for this app. Same error.
Any help?
Hi Orlando,

With regards to your question about extensions you are correct. The trial servers don't allow the publication of extensions, however this shouldn't manifest itself has timeouts but rather as error messages indicating that extension publication isn't available.
Cloud you please PM me your trial address so I can follow up and understand why you are experiencing these timeouts.

Now about the login issue can you share the app that's giving you trouble and a more detailed error message ?

Best Regards
David Nunes
Hi Orlando,

Have you upgraded EM? Did you follow the instructions in the upgrade document, namely configuring single-sing-on and then republishing all espaces?

Cheers,
Tiago Simões
Hi,

The local version I did upgrade as per the instructions and the app is working.
In the cloud tried to go around the timeout error and tried to publish indidual components (smaller size so as not to have timeouts). That's when found the hard way that extensions cannot be published in the trial version.
In the process I most probably left EM with broken links to other components, as the extensions were not transfered.
Aplications from Version 6 have no login problems. Only those upgraded.

So I have the question: Is there any way to run in the trial cloud an "upgraded" app from version 5.1?

Thanks for your help and sugestions.

David, I will PM you with the add details.
Hi Orlando,

Thank you for the info.
Unfortunatly you won't be able to run that 5.1 upgraded app because it requires some extensions from Enterprise Manager to be published.
You can either run them from an on premise instalation or if you don't have a machine available you can run it on Amazon.

With regards to the timeouts you felt if you would be so kind as to share some extra information:
Are you behind a corporate proxy ?
Could you ping your trial server and share the results ?

Thank you for helping us imporve our services.

Best Regards
David Nunes
Hi all,

Is there already some documentation on how to migrate from 5.1 users/user_master/permissions to the new User/Role/Group structure ?
Not using Enterprise Manager !!

Is there a document describing the use of Groups

Regards
Hi Joop,

You can check "Upgrade from version 5.1\Enterprise Manager Upgrade to 6.0.pdf" inside EnterpriseManager.zip to see what has changed and understand your options. If you were using EnterpriseManager before you'll want to continue using it as you have user data in its tables. What you can do now is to remove whatever you were not using and just leave the USER_MASTER entity to create global extensions to the User entity.
Permission Areas will be automatically converted into Roles. Groups are a bit similar to EM Roles, has they can group users and roles.

To understand the use of groups you can check How to manage users and roles?

Let me know if you have any further questions.

Cheers,
Tiago Simões

Where is "Upgrade from version 5.1" Folder?

Is it on the website or somewhere else?
Answer my own question
It is in the Download: Enterprise Manager.
http://www.outsystems.com/NetworkSolutions/ProjectDetail.aspx?ProjectId=64
After deploy the new Enterprise Manager, for some reason my admin password doesn't work any more.
Other user can still login to espace Enterprise, but not admin. Login fail because wrong username or password.

Is anyway to get the admin password?
Hi Richard,

Well, I would expect that the admin password wouldn't have changed. If you want to try and somehow reset the admin password, I would suggest you contact our support department. They may have some ways to do so ;)

Regards,

Paulo Tavares
Hi Richard,

>After deploy the new Enterprise Manager, for some reason my admin password doesn't work any more.
>Other user can still login to espace Enterprise, but not admin. Login fail because wrong username or password.

Can you describe your upgrade process with more detail? When were your users created? The admin you refer was the "Users" administrator?
Did you try admin/admin?

>Is anyway to get the admin password?

There is no way to obtain a user password, you need to reset or change it. If you don't have admin privileges, you need to publish an eSpace that creates a new administrator user.
 
Application (Order) was developed in Agile Plateform 5.1

Upgrade process:
  1. Download and install Agile Platefrom 6.0
  2. Download Enterprise Managers from Downloads (http://www.outsystems.com/NetworkSolutions/ProjectDetail.aspx?ProjectId=64)
  3. Double click and deploy it (EM) to server.
  4. Download espace (Order) from server. Add / remove reference, 1-click publish : Successful
  5. Browse the link, has no problem
  6. Second day, admin cannot login. Login and Password incorect.
Fix Process
  1. Change espace (Order) to use "Users" in User Provider espace.
  2. Admin cannot log on. Other users can logon but see nothing
  3. Change espace (Order) to user "EM" in User Provide espace.
  4. Admin account didn't work, Other users can logon and see contents
  5. Using another user (has administrator privilege), change the admin password
  6. Work now.