[Agile Project Management] Discussion

[Agile Project Management] Discussion

  
Forge Component
(18)
Published on 2013-03-08 by Nuno Antunes
18 votes
Published on 2013-03-08 by Nuno Antunes
Can you give me the login information for this Application.  I've tried the typical default Admin UID & password, also my service center Admin UID & PWD and neither work.

Thanks in advance for your help

Henry
Hi Henry,

Have you bootstrapped the Agile Project Management espaces, in Enterprise Manager?
If so, then the login credentials you should use are the Enterprise Manager Admin credentials.

Regards,
Vitor Oliveira
Is this ANP but then to be installed locally ?
Is this released and maintained by OutSystems ?
Is it Version 6 compliant ?
Hi Joop,

This component is a simpler version of ANP made to work disconnected from the Network.

As all components, Agile Project Management is to be maintained by our community.

And we never tried it on the 6.0 version. I'd say it should work, but you'd have to install the new Enterprise Manager version also.

Regards,
Vítor Oliveira
Is there a online/hosted version of this application for outsystems customers?
Hi Robert,

There isn't. The application actually got started as hosted product which we sold as a subscription to customers under the umbrella of the agile network but it was something we decided to discontinue about a year ago.

As such we have decided to make it open source and make it available for the community.

All the best,
  Pedro
Pedro, 

Thanks for clearing that up, (I do remember using it in the agile network so I was wondering about it, hence the question).




Does anyone know if APM content can be migrated over from one environment/server to another? We would like to install it on our QA environment but that environment is not completely ready. Can I install it on our DEV environment and later migrate everything over once ready?

In the installation guide, it describes how you can import projects from ANP but doesn't mention if/how you can import projects from another instance of APM. I would assume there is a way?

Thanks.
Hi Leo,

Unfortunately that feature is not supported.
One can only import projects from the Outsystems Network to the Agile Project Management component, and not between APM instances.

Regards,
Vítor Oliveira
Would be nice to import sizings made on the network into this APM ... 
HI Joop,

That is in our roadmap.

Regards,
Vítor Oliveira
Vitor: any timeframe ??
Hi Joop,

Not yet. It is on our backlog. Stay tuned ;)

Regards,
Vítor Oliveira
I've downloaded the latest version of the APM solution as I was told by support to get passed an issue we are having with mapping ECTs to APM. By doing so, it neither fixed my broken referencing issues nor my ECT mappings.
In fact, it has actually broken my APM component to the point that I cannot open it.
I've followed up with support with detailed information to my issues, however I haven't been replied to in 3 days.

There appears to be multiple issues on our end, but one that I am seeing is ECT_Server_Connector is referencing the ECT_GetSubscriptionAddress action from ECT_Provider, however when updating references, it shows that this action is no longer public, therefore breaking the use of that action on update.

ECT_Provider is a system espace that cannot be open by service studio, so how does one fix this issue?

Thanks.
Hi Leo,

Which version of the ECT component are you using?

APM requires the use of ECT version 5.1.7. Please check it and let me know if the problem still persists.
You can find the 5.1.7 version here.


Regards,
Vítor Oliveira
Sorry for not replying to this sooner. After reading your last post, i noticed that we didn't have a compatible version of ECT. After downloading and installing version 5.1.7 I was able to publish the APM solution without any broken references.

I was also able to finally enable ECTs to flow in from the localalized dev environment. ONE issue still remains there. It seems like the APM timer pulling new ECTs is pulling back the 1 most recent ECT when no new ECTs were created. So the issue list in APM now has multiple of the same ECT. Data Issues? I don't know.

I am still looking into mappings ECTs from a separate environment, since I have not had luck with that since.

Thanks,
Leo.
I think i've found an issue in ECT_APM_Connector espace, in GetFeedbackToSync_External action. There is no condition in the query that prevents it from continously pulling back ECTs that have already been sync'd.
I believe there should be a join to Feedback_Extended_Amt, to see if that feedback has already been marked as sync'd?

We've noticed this, because any ECT that is submitted from an external environment, keeps reapearing and duplicating everytime the timer refreshes the issue list.

I'm going to attempt to fix this locally. I can update the espace after if i can prove it worked, and someone can verify my correction.

Thanks.
Here is the query I put in to fix our local version of APM.

SELECT {FEEDBACK_SERIAL}.*,{FEEDBACK}.* 
FROM ({FEEDBACK_SERIAL}
Inner JOIN {FEEDBACK} ON {FEEDBACK_SERIAL}.[Id] = {FEEDBACK}.[Id])
WHERE {FEEDBACK}.[Id] not in
(
 SELECT {FEEDBACK_EXTENDED_AMT}.[Id]
 FROM {FEEDBACK_EXTENDED_AMT}
 WHERE {FEEDBACK_EXTENDED_AMT}.[IsAMTSync] = 1
)
I've also found that ECT screen shot views do not work in this version of APM.

Here is what I did to fix our local version.

In AgileManagement eSpace, in 3 locations, the ECT_URL is set to PagePreview.aspx?GUID=

I've changed it to /ECT_Provider/PagePreview.aspx?GUID=

I'm not sure if it's the correct answer but we can at least now see the screen shot.
An issue still remains with the description pop up displaying in the top left instead of the actual screen location.
@Vitor:

The webservice to get the sizing from ANP (http://www.outsystems.com/SizingTool/SizingToolExternal.asmx?wsdl) is very useful.
Almost everything is exported except the packages. Is there a possibility to have those as well ??

Regards,
Joop
Can anyone confirm whether this is definitely version 6.0-compliant? It was mentioned that it should be but the commenter said they'd not tried it.

If it is v6.0-compliant, please can you confirm exactly what needs doing to use it?

Thanks!
Hi Everyone,

there is an issue with ECT 5.1.9 and 5.1.10, where a method was removed from these versions that is still used in APM. 

There is a simple fix for this as the method is no longer needed inside APM, so you need only remove the reference and all usages of the method inside APM modules (there are only two).

Regards,
João Atalaia.
Iain Fogg wrote:
Can anyone confirm whether this is definitely version 6.0-compliant? It was mentioned that it should be but the commenter said they'd not tried it.

If it is v6.0-compliant, please can you confirm exactly what needs doing to use it?

Thanks!
 
 I am trying to install it on 6.0, but I keep getting broken references with the RichWidgets, both with the 5.1.11 version as the 6.0.0 version of the RichWidgets, and I can't publish the APM solution successfully. Does anyone else have experience with this?

Is an APM version for 6.0 (or higher) going to be released?
In the mean time I managed to get rid of all broken references to create a 6.0 version except one, which was already submitted before:

ECT_Server_Connector is referencing the ECT_GetSubscriptionAddress action from ECT_Provider, however when updating references, it shows that this action is no longer available, therefore breaking the use of that action on update.

ECT_Provider is a system espace that cannot be opened by service studio, so how does one fix this issue?


The answer then was to download the "new" ECT 5.1.7 version, but now I am already on 6.0, so ECT is already installed as part of the platform.

How to solve this?

Cheers,
Annemarie
Hi Everyone,

I am having the same problem with
eSpace ECT_Server_Connector on version 6.0, this eSpace uses missing references and have broken references because the 'ECT_GetSubscriptionAddress' Action was not found in the 'ECT_Provider' eSpace definition.

How can I solve this?

Regards,
Miguel Oliveira
Hi Annemarie Sonnenberg and Miguel Oliveira,

I believe João Atalaia has posted a solution for the ECT problem. Please check it above.

Regarding releasing a 6.0 solution, there is no plan for it to happen.
As all the other components, this one belongs to the community and it's open for upgrade and improvement by everyone.

Regards,
Vítor
 
 
Vitor Oliveira wrote:
 
Ah, that solves the problem.

I have a 6.0 solution, and removed the IPP. I can't upload it, when submitting a reply the postback keeps failing, both from our company network, as from an regular internet connection.

Vitor, I will send it to you. Can you then upload it?

Thanks,
Annemarie
Annemarie Sonnenberg wrote:
 
Ah, that solves the problem.

I have a 6.0 solution, and removed the IPP. I can't upload it, when submitting a reply the postback keeps failing, both from our company network, as from an regular internet connection.

Vitor, I will send it to you. Can you then upload it?

Thanks,
Annemarie
 

Yes Annemarie, you can send it to me and I'll upload it.

Thanks,
Vítor
Here's Annemarie's 6.0 version of the Agile Project Management component.

Thanks Annemarie! :)
First thanks a lot to all that have taken the effort to make APM compatible with versie 6.0!

But.... we use version 7 now. Anyone have any experience with this version and APM?

Regards Barry
Hi everyone,

is it possible to have this solution with the Outsystems v7?
I'm trying but with no luck =( .... there are too many circular dependencies, specially between the eSpaces AgileManagement and ProjectSite.

Thanks in advance.
Hi,

How many SU uses the APM?
I'm trying to test APM on community edition, it returns that i do not have SU.

Tnks
vilhena wrote:
Hi,

How many SU uses the APM?
I'm trying to test APM on community edition, it returns that i do not have SU.

Tnks
 On a 7.0 Platform installation, you should have at least 114725 Su's

Espace:Name Report_Su:OMLComplexity
ProjectSite 66063
AgileManagement 24749
APM_Documents 8151
ECT_APM_Connector 7297
ProjectSiteReports 6552
ECT_Server_Connector 1233
Sorting 598
WidgetLibrary40 82
Total 114725
 

Kind regards

Daniel Martins.
Hello..
Hope someone can help me on this issue.
I'm trying to import some projects from the old ANP but I'm having some problems.
I almost all the projects, I'm getting the following error in the last step of the import step:



The error logged in Service Center is the following:

An error occurred while adding the file to the storage: Could not add document to storage: Cannot insert duplicate key row in object 'dbo.OSUSR_5WO_STORAGECONTROL' with unique index 'OSIDX_OSUSR_5WO_STORAGECONTROL_17STORAGELOCATIONID'. The duplicate key value is (<NULL>).
The statement has been terminated.

This is happening in the action DS_DocumentAdd from the eSpace APM_Documents because it tries to create the entity with a Document Id = null, but I can't find problem in the documentation.
Can anyone give me a fix and explain the reason for this to occur, since I didn't want to change the solution before asking the community?

Thanks in advnce.

Kind Regards,
Gonçalo Martins
Are there any plans to make it work on Java stack?
Hi thirupathi

I believe the project team has no plans to keep evolving this - except for some minor bug fixing in things we might find during our usage of it. 

If you wish to use this in Java I would suggest you do the adapting yourself. Most of the effort should come out of the advanced queries - adapting them to Oracle, as they are built for SQL 
Server. I don't recall any extensions there so that should be one less issue there. 

Cheers,
Acácio 
Hi,

We are using Platform v9.0, and I am looking for a change management tool. This sounds like what I am after, but will it work in v9.0, and\or are there better options available now?

Regards,
Dan.