I Got an error "This module has an outdated User Provider"
Question

I got this error when I changed the user provider to another that I created, and then I put back to default user provider "User". 

Only one of my module has this error. I alread updated all the dependences and the error stiil.

error.jpg

Hi,

Similar thread is already available. Please find the below links for your reference.

https://www.outsystems.com/forums/discussion/63900/this-module-has-outdated-user-provider/

https://www.outsystems.com/forge/component-overview/7593/user-provider-fix

Thank for you help!

mvp_badge
MVP

Hello Diel,

Hope you're doing well.

Are you talking about a warning that appears in Service Center, right?


You can try to do a couple things in order to fix it:

1) Try to change your User Provider to the module itself, then publish. After that, change the User Provider back to "Users" and publish again.

2) If that doesn't work, you can consider to use this Forge Component: User Provider Fix.


Basically, this information about a module having an outdated User Provider is stored in the database. Sometimes it happens when there is an inconsistency in the information stored.

You can use that component, it is going to change the flag directly in the database and the warning should disappear :)


Hope that this helps you!


Kind regards,

Rui Barradas

Hi,

Similar thread is already available. Please find the below links for your reference.

https://www.outsystems.com/forums/discussion/63900/this-module-has-outdated-user-provider/

https://www.outsystems.com/forge/component-overview/7593/user-provider-fix

Thank for you help!

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.