Error Installing Agile Platform 6.0 on Windows 7

Error Installing Agile Platform 6.0 on Windows 7


I'm trying to install the community edition of the Agile Platform on Windows 7. How ever I get the error in the picture. My IIS is started before the install, when I get to this part I check the IIS, it's stopped, but I restart it and click on retry and still get the same error.

In the OutSystemsInstall.log file there's this entry...

[08.06.2011 17:14:57] Creating Platform database 'outsystems'.
[08.06.2011 17:15:03] Required Admin permissions granted to user 'OSAdmin' on catalog 'outsystems'.
[08.06.2011 17:15:03] Required Runtime permissions granted to user 'OSRuntime' on catalog 'outsystems'.
[08.06.2011 17:15:03] Required Admin permissions granted to user 'OSLog' on catalog 'outsystems'.
[08.06.2011 17:15:03] Platform Database schema will be upgraded in catalog. This process may take a while.
[08.06.2011 17:15:03] Platform Database model was successfully upgraded.
[08.06.2011 17:15:05] SQL Server and ASP.NET were sucessfully configured to support persistent sessions.
[08.06.2011 17:15:09] Error: O índice estava fora do intervalo. Tem de ser não negativo e inferior ao tamanho da colecção.
[08.06.2011 17:15:09] Nome do parâmetro: index
[08.06.2011 17:15:09]    em System.Collections.CollectionBase.System.Collections.IList.get_Item(Int32 index)
[08.06.2011 17:15:09]    em System.DirectoryServices.PropertyValueCollection.get_Item(Int32 index)
[08.06.2011 17:15:09]    em OutSystems.HubEdition.ServerCommon.Utils.PlatformUtils.CreateVirtualDirectory(String name, String path, String[]& replacedVdir)
[08.06.2011 17:15:09]    em OutSystems.HubEdition.ConfigurationTool.ConfigurationFrm.#cVb()
[08.06.2011 17:15:11] The Platform Server configuration was not completed. The Configuration Tool failed with error code 7
[08.06.2011 17:15:11] The Configuration Tool failed with code 7. Asking for IIS repair/retry

I have .NET, IIS7 and I can access the Default Web Site, and SQLSERVER.

Any ideias?

Thanks in advance.
Also I'd like to add that my firewall is turned off and antivirus deactivated. Thanks.
Hi M. Vieira,

It appears that your IIS has some configuration problem or misssing components that are causing this error.
You already had IIS installed before installing the Agile Platform, right?

If so, please check that the following components are installed:

Make sure you have the IIS 6 Managament Compatibility component installed, since it is required by the Agile Platform.

Alternatively you can also fully uninstall IIS, restart your computer and run the community installation again. It will install IIS automatically with all the required components.

Hi Ricardo,

I've tried uninstalling IIS7 and reinstalling it then running the outsystems installer, I've also tried uninstalling it and letting the outsystem's installer take care of IIS. Yet I keep getting the same error.

In uninstalling IIS7 I've unchecked the component from the Windows Features section and after a reboot I've done the same for the Windows Process Activation Service.

Any ideas?
Thank you for your reply.

It appears that your machine configuration has some kind of problem that's preventing IIS to work correctly, and I suppose that configuration is not being deleted when you uninstall IIS. Please try to do the following:
1. Uninstall IIS from Windows Components
2. Manually delete all files in C:\Windows\System32\inetsrv\config
3. Delete IIS Metabase, by deleting C:\Windows\System32\inetsrv\MetaBase.xml and C:\Windows\System32\inetsrv\MBSchema.xml

Please let us know if this worked.

Best Regards,
Ricardo Ferreira
Hi M. Vieira,

What version of the Windows 7 are you using?

João Rosado
I'm going to try deleting the config files and metabase. João, I'm using Windows 7 Professional.
Well deleting the config files didn't work. I ended up running into this situation. I'm going to keep on trying. Thank you for your help.
Hi M. Vieira

Yes, like the post you linked says you need to also reinstall the "Process Activation Service" for it to replace the deleted files.

João Rosado
I've uninstalled WAS, then uninstalled IIS then reinstalled IIS. And tried to install the agile platform but was unable, I keep on getting the same error. IIS is up and running and everything seems to be fine. However, when I get to the part that it shows the error, I check IIS and it's off. The outsystems application pool is created but has no applications.

For now I'll probably opt for installing the agile platform on a Windows XP virtual machine.

Thank you all for your help.