upload widget blocked after approval to access the photos

I'm using the upload widget. When I install my mobile app for the first time and I login, and then upload an image, it is display the pop up that by default, to accept user photo sharing. So far so good.

But then I click on the upload again and nothing happens, nothing is displayed to select the files (the widget stays blocked). If I close the app and open it again, and click on upload again, I'm already able to select a file and the entire procedure is done correctly. 

Does anyone know why the widget has this behavior and if it is possible to solve?

I opened a Support Case for this and this issue is acqnowledged by Outsystems. 

They will try to fix this in a few months.

Hi Sara,

I made some tests on a test app, and opened it as a PWA both on IOS and Android, without being able to reproduce your issue.

Is there a chance you can share a small test app where you're having this issue, so I can have a more detailed look?

Thank you.

Best regards,

Paulo Moreira

Hi Paulo!

Thanks for the answer. I installed my app on my phone (without pwa). If I install as pwa it works. But the option for Native platforms it doesn't.



UploadTest.oml

Hi!

I'm having the same exact problem. I give permissions, then the widget doesn't work until I open the app again. PWA is not an option for my case.

I also have exactly the same problem. Allthough the wordkaround is easey, I hope it will be solved soon.

@Jaacov de Leeuw could you share your workaround? I also did a workaround and used the camera plugin (ChooseImage).

@Sara Silva I do not have a workaround. Camera plugin will not work for me as it is not compatible (yet) with MABS 8.0.

I'm having the exact same issue. Let me know if you find a workaround / solution for this.

I opened a Support Case for this and this issue is acqnowledged by Outsystems. 

They will try to fix this in a few months.

Thanks @Jaacov de Leeuw. I did the same, I also opened a ticket. Outsystems said that they will investigate the issue.

I ran into the same issue.

As a temporary workaround, I used the Native Permissions & Settings plugin.

In the OnReady event of the screen where I have the Image Upload widget, I have used the CheckCameraAuthorization and RequestCameraAuthorization client actions to ask for the permissions if they are needed.

The result for the end-user is similar and I can upload an image without having to close and open the app again.

This issue seems to be solved. This morning I generated a new apk and the problem did not occur anymore.

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.