Debugger Not Working
Application Type
Reactive

Hello,

Scenario - We have to debug a server action where I want to check responses coming from API which is encapsulated in server action with some more logic. Let us call action with API and logic as action A

Problem- Debugger does not even hit the Start of action A

CommunicationException: Request failed with an error
at https://rcsi-tst.outsystemsenterprise.com/PAMainPortal/scripts/OutSystems.js?OPjyhkVD_VNUyv8gjuX9hw:2:30741
    at XMLHttpRequest.<anonymous> (https://----outsystemsenterprise.com/PAMainPortal/scripts/OutSystems.js?OPjyhkVD_VNUyv8gjuX9hw:2:26607)


Please note that None of the modules are outdated. All dependencies are refreshed

The API was created using Outsystems right?

Check this post please

https://www.outsystems.com/forums/discussion/66723/how-can-i-debug-a-cs-module-from-an-api/

Kind regards,

Márcio

We are consuming from a backend called Oracle JDE. We have noticed that step into does not work.

But Step over works perfectly fine. We need Step into to examine logic in action A

 

Hello T08,

please check in service center error log,

I got same issue many time it is connection issue from server.

Regards,

Ajit kurane.

Though it says "Request fail with an error" we are getting response from API.

the stack track is as below

CommunicationException: Request failed with an error
at https://rcsi-tst.outsystemsenterprise.com/PAMainPortal/scripts/OutSystems.js?OPjyhkVD_VNUyv8gjuX9hw:2:30741
at XMLHttpRequest.<anonymous> (https://----outsystemsenterprise.com/PAMainPortal/scripts/OutSystems.js?OPjyhkVD_VNUyv8gjuX9hw:2:26607)

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.