When uploading and publisch an espace

When uploading and publisch an espace

  
This happens on windows 2008 server

Error Summary

HTTP Error 404.13 - Not Found

The request filtering module is configured to deny a request that exceeds the request content length.

Detailed Error Information
Module RequestFilteringModule
Notification BeginRequest
Handler PageHandlerFactory-ISAPI-2.0-64
Error Code 0x00000000
Requested URL http://emsk:80/servicecenter/eSpaces_List.aspx
Physical Path D:\Program Files\OutSystems\Platform Server\running\ServiceCenter.22816958\eSpaces_List.aspx
Logon Method Not yet determined
Logon User Not yet determined
 
Most likely causes:
  • Request filtering is configured on the Web server to deny the request because the content length exceeds the configured value.
Things you can try:
  • Verify the configuration/system.webServer/security/requestFiltering/requestLimits@maxAllowedContentLength setting in the applicationhost.config or web.config file.
Links and More InformationThis is a security feature. Do not change this feature unless the scope of the change is fully understood. You can configure the IIS server to reject requests whose content length is greater than a specified value. If the request's content length is greater than the configured length, this error is returned. If the content length requires an increase, modify the configuration/system.webServer/security/requestFiltering/requestLimits@maxAllowedContentLength setting.

View more information »

Hi Martijn

That problem is covered in the installer checklist (and done automatically if it was a community installer).

Here are the checklist steps you missed:
Microsoft Internet Information Services 7:
  • Edit your %WINDIR%\Microsoft.NET\Framework64\v2.0.50727\CONFIG\machine.config file:
    1. Locate the <system.web> section
    2. In the <processModel> element, under the <system.web> section (create it if it doesn't exists), configure as follows:
      • autoConfig attribute must have the value true.
    3. Locate the <httpRuntime> tag (tip: look for text <httpRuntime using your text editor). If it does not exist, create it below the <processModel> tag.
    4. In the <httpRuntime> element, set the maxRequestLength attribute to 32768 (for small factory environments), 65536 (medium sized factory environments) or 131072 (large factory environments). This value is in KBytes. You should end up with something similar to <httpRuntime executionTimeout="100" maxRequestLength="131072" />
  • Edit your %WINDIR%\system32\inetsrv\config\applicationHost.config file:
    1. Locate the <system.webServer> tag. Make sure it is not one that is preceeded by a <location> tag in the previous line. Its full path should be <configuration>\<system.webServer>
    2. Within the <system.webServer> section, locate the <security> sub-section
    3. Find the <requestFiltering> sub-section
    4. Find the <requestLimits> element inside <requestFiltering>. If it does not exist, create it immediately above </requestFiltering>
    5. In the <requestLimits> element, set the maxAllowedContentLength attribute to 33554432 (for small factory environments), 67108864 (medium sized factory environments) or 134217728 (large factory environments). This value is in Bytes. You should end up with something similar to <requestLimits maxAllowedContentLength="134217728" />

Regards,
João Rosado