[OutDoc] [OutDoc] Error: Object reference not set to an instance of an object error
outdoc
Web icon
Forge component by Platform Maintenace
Application Type
Traditional Web
Service Studio Version
11.14.0 (Build 54183)
Platform Version
11.10.4.29633

Hello guys,

I saw other posts with the same error we are having, but, and after trying several things like remove old module versions, redeploy the modules through service center... We are still having the error.

I also tried to install a previous version of Outdoc but also without success.

Does anyone manage to solve this error?


Best Regards,

Diogo Miguel

Hi all

There is a bug inside the OutDoc application. Sometimes it is possible to use the 1-click publish option from Service Studio to bypass the bug because this process can change\validate some properties of the OML file, and the value of these properties can modify how the validation process is executed, avoiding the flow with the bug.

But this approach only works for some modules.

Unfurtnaly there aren't more options to apply in the OML file to bypass this bug.

Currently, we are planning to fix this bug as soon as possible and deliver it in a successive release.


Kind regards

Javier Hermoso

OutSystems developer

mvp_badge
MVP

Hi,

Same issue here.

Hope someone from the team can have a look what is going on.

Kind regards,

Johan den Ouden

Hi all

There is a bug inside the OutDoc application. Sometimes it is possible to use the 1-click publish option from Service Studio to bypass the bug because this process can change\validate some properties of the OML file, and the value of these properties can modify how the validation process is executed, avoiding the flow with the bug.

But this approach only works for some modules.

Unfurtnaly there aren't more options to apply in the OML file to bypass this bug.

Currently, we are planning to fix this bug as soon as possible and deliver it in a successive release.


Kind regards

Javier Hermoso

OutSystems developer

mvp_badge
MVP

Hi Javier,

Thanks for the update. Unfortunately the re-publish won't solve the issue for me.
I will wait for the bug fix.

Thank you very much.

Kind regards,

Johan den Ouden

Hi all,
There is a new version of OutDoc with this bug fixed.
You can download from Forge as usual.

Thank you very much for helping us to improve the product!!
Kind regards
Javier Hermoso

Champion

Hi,

The newest version of 8.0.7 had this problem for me :


Thanks

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.