Icon
Application Type
Traditional Web

How can I solve this issue to show the icons on calender widget & pagination as well as whole screen of this application whenever we needed.

I run this on my personal it works.

But in my enterprise, it doesn't show the icons even on the notifications too.

Inspected everything and applied CSS class for "pika" as

.pika-prev:before {

   content: "\f104"

    font-size: var(--font-size-h5);   

    position: relative;

still I can not see the icons....is there any solution to overcome this or any component which i yet to see? 

This is my issue:

Thanks And Regards,


Cetric




Solution

I have, but I needed to see. I have some experience, but it depends always on what you are doing.

1- You need to have the files of the icons updated on your environment/application/module

2- you have to check the font faces on your theme, and not forget the font family

3-on the style classes you need to see if you are putting the right class, maybe its missing something and that's why it's not getting the icon

4-you need to put the icon files as deployed to the target directory

It would be great if I could see module :(


Normally you need also the font family of the icons that you are using. Or the URLs to the files with the fonts is different. You need the files deployed to the target directory. You need the font faces. There is a lot of things that could be wrong in your development, the best way is to have a look. But I would try to do everything from the beggining.

Follow the steps

https://www.osquay.com/knowledge-center/how-to-add-new-icons-to-your-outsystems-apps-using-existing-icon-fonts



thanks brother for yours kind reply...but i tried alot....do you have any idea how to implement that?

Solution

I have, but I needed to see. I have some experience, but it depends always on what you are doing.

1- You need to have the files of the icons updated on your environment/application/module

2- you have to check the font faces on your theme, and not forget the font family

3-on the style classes you need to see if you are putting the right class, maybe its missing something and that's why it's not getting the icon

4-you need to put the icon files as deployed to the target directory

It would be great if I could see module :(


Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.