[OutSystems Charts] Column Chart Data is not generating
outsystems-charts
Reactive icon
Forge component by Platform Maintenace
Application Type
Reactive

Hi

when i am trying to develop Column Chart in my Personal Env.it is working properly.in client env Chart is not generating.attched High Chart data which i am generating.

Highchart.txt

Good afternoon @Arkyadeep Bharadwaj 

Thank you very much for your feedback, I've tested with your advance format and It wasn't possible to replicate the issue.
I'll need a bit more info: What's the error, does it have any Feedback Message? Do you know which is the version of OutSystems Chart in the client env.?

Thanks,
João Ferreira

No i am not getting feedback message.In Client Env we are using version-Version 1.3.5 .when i am using personal env it is working.but when i am doing in Client env chart is not working.same table  same code i am using.attachi g Oml File.please check the attachment.

page name is 

Week_Chart_Report
LGB_REPORTS_ORDERSATZ_UI.oml

Sample app i am attaching.this application is working in my personal environment

ChartSample.oml

It is supposed to show this?


Did you try to compare the versions of the Outsystems Chart between your personal and the client environment?

Regards,

Márcio

Version of Outsystems Chart in Client env is-1.3.5 

With help of 1.3.5 version is it possible to create Multicolor column chart.like below

now i am using 1.5.3 but Chart is not generating with help of HighChart data.attaching the OML file.can you check

ChartSample.oml

Hi @Arkyadeep Bharadwaj,

Sorry for all this waiting, I think I've found the root cause, and I think I've a workaround for you.

Try to add an empty record to your DataPointList or add a list item directly in the SourceDataPointList InputParameter. I think this will solve your issue.

Context: The code older than version 1.3.9 needs records on SourceDataPointList to render the chart, we've fixed that on the latest versions. 

If it's possible you can also try to update the version of the charts to a recent one, and see if the issue persists. If there is anything on the charts side that we could help, don't hesitate to reach us again.

Let me know If this solution works for you,

Regards,
João Ferreira





Is it possible can u share the oml file?

Hi @Arkyadeep Bharadwaj,

Here you have the .oml, let me know if this works for you.

Regards,
João Ferreira


ChartSample_solution.oml

one thing how to enable horizental scrollbar?

Hi @Arkyadeep Bharadwaj ,

Ok here we have two challenges, show all xAxis labels and config xAxis scroll bar.

  1. To make sure we display we need to config the labels with a step: 1, (Highcharts link)
    1. This is will update the labels but they will overlap each other and the xAxis will be eligible.
      To prevent that you can rotate the labels (as they do by default), I applied a rotation of -70 (Highcharts link)
  2. To config the xAxis scroll you have to add the scrollablePlotArea config to your chart config. (Highcharts link) This new object allows you to config the minWidth that will trigger the scroll behavior, and the initial place of the scroll bar.
    I have config the minWidth with 900 and the scrollPositionX as 0.

You can find this working under the Sample screen.

Let me know if this works for you,
Regards,
João Ferreira

ChartSample_solution.oml

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.