New Oustsystems 6.0 Install Stalls at Service Center Install

New Oustsystems 6.0 Install Stalls at Service Center Install

  
This has been sent to support, but thought I'd send it to the forums as well.

I've been running 5.1 for awhile and decided to install the 6.0.  The installation bombs when it gets to deploying the ServiceCenter eSpace.  I've completely stripped everything out (including IIS) to get a clean install and it still bombs.  I try to re-run the 5.1 installers and can't re-install that now either...bombs in the same place.

The error that comes up on the 6.0 installer says "it appears there is a WEB.CONFIG file that is overriding the configuration changes made by the Outsystems."  Or something similar to that.

When I run the SCInstall.bat file manually, here is what comes back:

C:\Program Files\OutSystems\Platform Server>scinstall.bat
Service Center Installer v6.0.0.4

Start installing Service Center v6.0.0.4...

Publishing Extension(s)...
Publishing Extension 'OMLProcessor'...
Publishing Extension 'IntegrationStudio'...
Reading ServiceCenter.oml oml file information...
Adding ServiceCenter eSpace to database...
Compiling ServiceCenter eSpace...
Preparing ServiceCenter eSpace deployment...
Deploying ServiceCenter eSpace...
Creating ServiceCenter default tenant...
Failed to ping... Will continue deploy anyway...
Message 1
  Id         : FailedTenantDeployment_PingAspx
  Type       : Error
  Message    : Error message from node lln00969 (127.0.0.1): Deployment failed
  Submitable : True
  Details    :
Deployment failed. Could not invoke ping. Exception: The remote server returned
an error: (500) Internal Server Error.
   at System.Net.HttpWebRequest.GetResponse()
   at OutSystems.HubEdition.DeployService.Deploy.#wSb(String hostname, String es
paceName, String ptaOrTenantName, String pingFile)Html/Text returned:"Server Err
or in '/ServiceCenter' Application.
 Parser Error Description: An error occurred during the parsing of a resource re
quired to service this request. Please review the following specific parse error
 details and modify your source file appropriately.

 Parser Error Message: Could not load type 'ssServiceCenter.Global'.

 Source Error:

 Line 1: <%@ Application Codebehind="Global.asax.cs" Inherits="ssServiceCenter.G
lobal" %>
 Source File: /ServiceCenter/global.asax    Line: 1

 Version Information:  Microsoft .NET Framework Version:2.0.50727.5446; ASP.NET
Version:2.0.50727.5420"
[HttpException] Could not load type 'ssServiceCenter.Global'.
   at System.Web.UI.TemplateParser.GetType(String typeName, Boolean ignoreCase,
Boolean throwOnError)
   at System.Web.UI.TemplateParser.ProcessInheritsAttribute(String baseTypeName,
 String codeFileBaseTypeName, String src, Assembly assembly)
   at System.Web.UI.TemplateParser.PostProcessMainDirectiveAttributes(IDictionar
y parseData)
[HttpParseException]: Could not load type 'ssServiceCenter.Global'.
   at System.Web.UI.TemplateParser.ProcessException(Exception ex)
   at System.Web.UI.TemplateParser.ParseStringInternal(String text, Encoding fil
eEncoding)
   at System.Web.UI.TemplateParser.ParseString(String text, VirtualPath virtualP
ath, Encoding fileEncoding)
[HttpParseException]: Could not load type 'ssServiceCenter.Global'.
   at System.Web.UI.TemplateParser.ParseString(String text, VirtualPath virtualP
ath, Encoding fileEncoding)
   at System.Web.UI.TemplateParser.ParseReader(StreamReader reader, VirtualPath
virtualPath)
   at System.Web.UI.TemplateParser.ParseFile(String physicalPath, VirtualPath vi
rtualPath)
   at System.Web.UI.TemplateParser.ParseInternal()
   at System.Web.UI.TemplateParser.Parse()
   at System.Web.UI.TemplateParser.Parse(ICollection referencedAssemblies, Virtu
alPath virtualPath)
   at System.Web.Compilation.BaseTemplateBuildProvider.get_CodeCompilerType()
   at System.Web.Compilation.BuildProvider.GetCompilerTypeFromBuildProvider(Buil
dProvider buildProvider)
   at System.Web.Compilation.BuildProvidersCompiler.ProcessBuildProviders()
   at System.Web.Compilation.BuildProvidersCompiler.PerformBuild()
   at System.Web.Compilation.ApplicationBuildProvider.GetGlobalAsaxBuildResult(B
oolean isPrecompiledApp)
   at System.Web.Compilation.BuildManager.CompileGlobalAsax()
   at System.Web.Compilation.BuildManager.EnsureTopLevelFilesCompiled()
[HttpException]: Could not load type 'ssServiceCenter.Global'.
   at System.Web.Compilation.BuildManager.ReportTopLevelCompilationException()
   at System.Web.Compilation.BuildManager.EnsureTopLevelFilesCompiled()
   at System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appMan
ager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, Host
ingEnvironmentParameters hostingParameters)
[HttpException]: Could not load type 'ssServiceCenter.Global'.
   at System.Web.HttpRuntime.FirstRequestInit(HttpContext context)
   at System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context)
   at System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr)


  ExtraInfo  :
CompModule : Broadcast Message
Preparing database...
Initializing Service Center...
ServiceCenter initialization failed. Failed to get HttpResponse from http://127.
0.0.1/ServiceCenter/DoBootstrap.aspx

Any help is appreciated.

All,

As always seems to be the case, as soon as I post something to the forum, the solution presents itself.  I figured out what was causing this problem...but I have no idea what caused the cause.

The Web.CONFIG file was missing in the "C:\Windows\Microsoft.NET\Framework\v2.0.50727\CONFIG" directory.  I copied the web.config.default file and renamed it web.config.  It appeared that without this file, the ".NET Trust Levels" for the web server were not functional, and therefore the web app didn't have permissions to install itself.  Once this file was in place, it worked fine.

Why this file was missing?  No idea.