Integration Studio: Invalid SSL Certificate / Value cannot be null.

We cannot use Integration Studio since a very old version of last year. Since the login form of Integration Studio was redesigned by OutSystems PD, it gives a HTTPS error and it does not allow to connect over HTTP too.

However, Service Studio prompts with a warning and it connects successfully.

The certificate using a browser is valid, since the root certificate is installed in Windows, but it seems OutSystems development environment is not clever enought to use the trusted root certificates from windows. 

We probably need a fix from OutSystems.


Integration_Studio_Error.png

Hi,

Do you have another URL under the certificate that can be used instead of the current one? I say this because, many times we can have an SAN certificate that have many domains and sub-domains, but only one is configured in the environment to be the primary one (I have a case in Cloud that we have the same problem and changed the URL for Integration Studio to the one configured as primary for the environment and it worked). 

I don't know if this can solve your problem, but, maybe you can take a look and try if possible.

Hope this can help you.


Best regards,

Ricardo Pereira

I'm also facing the same issue as Rossi.

My installation is on-premise in a hyper-v VM.

There's also an AD VM with a CA installed and it signs the certificate used for SSL.

My host computer is not joined to the AD VM but is able to access the service center and the SSL is verified and valid.

However, the service studio (11.14.12) throws the same warning as Rossi has provided but is able to connect.

The latest integration studio (11.14.12) throws the SSL error.

Attached is the log and the screenshot is below:

integration studio ssl.txt

I've contacted outsystems on the issue.

They're troubleshooting the issue but provided a workaround to my current version (11.14.12) of integration studio. Basically add ":80" without the quotes to your url to force it to http.

It'll give the insecure prompt and then integration studio should load.

Thanks, It worked !



Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.