[OutSystems UI Web] Is version 1.9.0 not compatible with older platform versions?
outsystems-ui-web
Web icon
Forge component by Platform Maintenance
Application Type
Traditional Web
Platform Version
11.12.0 (Build 30456)

When I try to publish OutSystems UI Web 1.9.0 in our environment, we get an error on the Template_TraditionalWeb, because the platform should be upgraded.

However, in the release notes there is nothing mentioned about a required platform version.

Solution

Hello.

As mentioned on the release notes, this version contains an update on the templates, associated and aligned with an update on the Users system module that is directly tight to a minimum Platform Server version (the feature is described here).
This is not an OutSystems UI Web particularity but is the way our platform works with new capabilities.
For any urgent fix you might try to manually download the OAP, unzip, and try to publish only the OutSystems UI Web module,

Best Regards,
GM

Thanks Gonçalo, for me it was not immediately clear that the UnifiedLoginUrl had something to do with the new version of the platform.

 It would be nice if there was a section ‘Compatible with’ to see if I can install the version or not, like in version 1.8.15.

Hello @Twan Walen
That information about compatibility is an automatic operation done by Forge.
We already reported that to our internal Forge team because as you mentioned, that information should be present indeed.

Best Regards,
GM

Hello @Twan Walen
Just to inform you that our Forge team already fixed the issue and now you can see the usual information about the compatible PS versions (here).

Best Regards,
GM

Hello there!

I had that problem when I had to upgrade from the service centre. What you need to do is clean all the dependencies and see what is wrong or not. You can have a big picture from the lifetime where you can see all the applications and where there are errors.

check if is everything ok with the template, if there are missing dependencies or if you have to install or upload.

Going to lifetime you are going to see what is needed, sometimes the warning is important, sometimes is not. And sometimes you have errors that you are not aware of. Have a look

Click here to go to lifetime




Kind Regards,

Márcio

Solution

Hello.

As mentioned on the release notes, this version contains an update on the templates, associated and aligned with an update on the Users system module that is directly tight to a minimum Platform Server version (the feature is described here).
This is not an OutSystems UI Web particularity but is the way our platform works with new capabilities.
For any urgent fix you might try to manually download the OAP, unzip, and try to publish only the OutSystems UI Web module,

Best Regards,
GM

Thanks Gonçalo, for me it was not immediately clear that the UnifiedLoginUrl had something to do with the new version of the platform.

 It would be nice if there was a section ‘Compatible with’ to see if I can install the version or not, like in version 1.8.15.

Hello @Twan Walen
That information about compatibility is an automatic operation done by Forge.
We already reported that to our internal Forge team because as you mentioned, that information should be present indeed.

Best Regards,
GM

Hello @Twan Walen
Just to inform you that our Forge team already fixed the issue and now you can see the usual information about the compatible PS versions (here).

Best Regards,
GM

Community GuidelinesBe kind and respectful, give credit to the original source of content, and search for duplicates before posting.